fish: Reimplement -i option using new C-based inspection.
[libguestfs.git] / fish / Makefile.am
index 3dc1a1e..9bc5b73 100644 (file)
@@ -1,5 +1,5 @@
 # libguestfs
-# Copyright (C) 2009 Red Hat Inc.
+# Copyright (C) 2009-2010 Red Hat Inc.
 #
 # This program is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
@@ -32,7 +32,8 @@ BUILT_SOURCES = \
 EXTRA_DIST = \
        $(BUILT_SOURCES) \
        rc_protocol.x \
-       guestfish.pod
+       guestfish.pod \
+       guestfish-bash-completion.sh
 
 guestfish_SOURCES = \
        $(generator_built) \
@@ -43,14 +44,17 @@ guestfish_SOURCES = \
        fish.c \
        fish.h \
        glob.c \
+       inspect.c \
        lcd.c \
        man.c \
        more.c \
        prep.c \
        rc.c \
        reopen.c \
+       supported.c \
        tilde.c \
-       time.c
+       time.c \
+       virt.c
 
 # This convenience library is solely to avoid compiler warnings
 # in its generated sources.
@@ -63,9 +67,12 @@ guestfish_CFLAGS = \
        -DGUESTFS_DEFAULT_PATH='"$(libdir)/guestfs"' \
        -DLOCALEBASEDIR=\""$(datadir)/locale"\" \
        -I$(srcdir)/../gnulib/lib -I../gnulib/lib \
+       $(LIBVIRT_CFLAGS) $(LIBXML2_CFLAGS) \
        $(WARN_CFLAGS) $(WERROR_CFLAGS)
 
-guestfish_LDADD = $(top_builddir)/src/libguestfs.la $(LIBREADLINE)
+guestfish_LDADD = \
+       $(LIBVIRT_LIBS) $(LIBXML2_LIBS) \
+       $(top_builddir)/src/libguestfs.la $(LIBREADLINE)
 
 # Make libguestfs use the convenience library.
 noinst_LTLIBRARIES = librc_protocol.la
@@ -101,3 +108,8 @@ guestfish.1: guestfish.pod guestfish-actions.pod
          --name "guestfish" \
          --release "$(PACKAGE_NAME)-$(PACKAGE_VERSION)" \
          > $@
+
+# Bash completion script.
+
+bashcompletiondir = $(sysconfdir)/bash_completion.d
+bashcompletion_DATA = guestfish-bash-completion.sh