New tools: virt-copy-in, virt-copy-out, virt-tar-in, virt-tar-out.
[libguestfs.git] / fish / Makefile.am
index f6b3e7d..972b13d 100644 (file)
 
 include $(top_srcdir)/subdir-rules.mk
 
+CLEANFILES = stamp-guestfish.pod
+
 bin_PROGRAMS = guestfish
 
 generator_built = \
        cmds.c \
+       cmds_gperf.gperf \
        completion.c \
-       guestfish-actions.pod
+       guestfish-actions.pod \
+       guestfish-commands.pod \
+       prepopts.h \
+       prepopts.c
 
 BUILT_SOURCES = \
        $(generator_built) \
+       cmds_gperf.c \
        rc_protocol.h \
        rc_protocol.c
 
@@ -33,23 +40,54 @@ EXTRA_DIST = \
        $(BUILT_SOURCES) \
        rc_protocol.x \
        guestfish.pod \
-       guestfish-bash-completion.sh
+       guestfish-bash-completion.sh \
+       virt-copy-in \
+       virt-copy-out \
+       virt-tar-in \
+       virt-tar-out \
+       virt-copy-in.pod \
+       virt-copy-out.pod \
+       virt-tar-in.pod \
+       virt-tar-out.pod
+
+# These source files (all related to option parsing) are shared
+# between guestfish and guestmount.  Keep a convenient list here just
+# so we know which ones are shared.  These files must not include
+# other guestfish files.
+SHARED_SOURCE_FILES = \
+       inspect.c \
+       keys.c \
+       options.h \
+       options.c \
+       virt.c
 
 guestfish_SOURCES = \
        $(generator_built) \
+       $(SHARED_SOURCE_FILES) \
        alloc.c \
+       cmds_gperf.h \
+       copy.c \
        destpaths.c \
        echo.c \
        edit.c \
        fish.c \
        fish.h \
        glob.c \
+       help.c \
+       hexedit.c \
        lcd.c \
        man.c \
        more.c \
        prep.c \
+       prep_disk.c \
+       prep_part.c \
+       prep_fs.c \
+       prep_lv.c \
+       prep_boot.c \
+       progress.c \
        rc.c \
        reopen.c \
+       rmsd.h \
        supported.c \
        tilde.c \
        time.c
@@ -59,6 +97,16 @@ guestfish_SOURCES = \
 librc_protocol_la_SOURCES = rc_protocol.c
 librc_protocol_la_CFLAGS = -Wall -Wno-unused
 
+# Build the command lookup perfect hash code.  The generated code has
+# lots of warnings so we must compile it in a separate mini-library.
+libcmds_la_SOURCES = cmds_gperf.c
+libcmds_la_CFLAGS =
+
+cmds_gperf.c: cmds_gperf.gperf
+       rm -f $@
+       $(GPERF) -t $< > $@-t
+       mv $@-t $@
+
 guestfish_CFLAGS = \
        -I$(top_srcdir)/src -I$(top_builddir)/src \
        -I$(top_srcdir)/fish -I$(top_builddir)/fish \
@@ -67,11 +115,12 @@ guestfish_CFLAGS = \
        -I$(srcdir)/../gnulib/lib -I../gnulib/lib \
        $(WARN_CFLAGS) $(WERROR_CFLAGS)
 
-guestfish_LDADD = $(top_builddir)/src/libguestfs.la $(LIBREADLINE)
+guestfish_LDADD = \
+       $(top_builddir)/src/libguestfs.la $(LIBREADLINE) -lm
 
-# Make libguestfs use the convenience library.
-noinst_LTLIBRARIES = librc_protocol.la
-guestfish_LDADD += librc_protocol.la ../gnulib/lib/libgnu.la
+# Make guestfish use the convenience libraries.
+noinst_LTLIBRARIES = libcmds.la librc_protocol.la
+guestfish_LDADD += libcmds.la librc_protocol.la ../gnulib/lib/libgnu.la
 
 if HAVE_RPCGEN
 rc_protocol.c: rc_protocol.x
@@ -87,22 +136,71 @@ rc_protocol.h: rc_protocol.x
        mv $@-t $@
 endif
 
-# Manual page.
-# guestfish-actions.pod is autogenerated.  There is no include
-# mechanism for POD, so we have to do it by hand.
-
-man_MANS = guestfish.1
-
-guestfish.1: guestfish.pod guestfish-actions.pod
-       sed \
-         -e '/@ACTIONS@/rguestfish-actions.pod' -e 's/@ACTIONS@//' \
-         < $< | \
-       $(POD2MAN) \
-         --section 1 \
-         -c "Virtualization Support" \
-         --name "guestfish" \
-         --release "$(PACKAGE_NAME)-$(PACKAGE_VERSION)" \
-         > $@
+# Script wrappers.
+
+bin_SCRIPTS = virt-copy-in virt-copy-out virt-tar-in virt-tar-out
+
+# Manual pages.
+
+man_MANS = \
+       guestfish.1 \
+       virt-copy-in.1 \
+       virt-copy-out.1 \
+       virt-tar-in.1 \
+       virt-tar-out.1
+noinst_DATA = \
+       $(top_builddir)/html/guestfish.1.html \
+       $(top_builddir)/html/virt-copy-in.1.html \
+       $(top_builddir)/html/virt-copy-out.1.html \
+       $(top_builddir)/html/virt-tar-in.1.html \
+       $(top_builddir)/html/virt-tar-out.1.html
+
+guestfish.1 $(top_builddir)/html/guestfish.1.html: stamp-guestfish.pod
+
+stamp-guestfish.pod: guestfish.pod guestfish-actions.pod guestfish-commands.pod
+       $(top_srcdir)/podwrapper.sh \
+         --man guestfish.1 \
+         --html $(top_builddir)/html/guestfish.1.html \
+         --insert guestfish-actions.pod:@ACTIONS@ \
+         --insert guestfish-commands.pod:@FISH_COMMANDS@ \
+         $<
+       touch $@
+
+virt-copy-in.1 $(top_builddir)/html/virt-copy-in.1.html: stamp-virt-copy-in.pod
+
+stamp-virt-copy-in.pod: virt-copy-in.pod
+       $(top_srcdir)/podwrapper.sh \
+         --man virt-copy-in.1 \
+         --html $(top_builddir)/html/virt-copy-in.1.html \
+         $<
+       touch $@
+
+virt-copy-out.1 $(top_builddir)/html/virt-copy-out.1.html: stamp-virt-copy-out.pod
+
+stamp-virt-copy-out.pod: virt-copy-out.pod
+       $(top_srcdir)/podwrapper.sh \
+         --man virt-copy-out.1 \
+         --html $(top_builddir)/html/virt-copy-out.1.html \
+         $<
+       touch $@
+
+virt-tar-in.1 $(top_builddir)/html/virt-tar-in.1.html: stamp-virt-tar-in.pod
+
+stamp-virt-tar-in.pod: virt-tar-in.pod
+       $(top_srcdir)/podwrapper.sh \
+         --man virt-tar-in.1 \
+         --html $(top_builddir)/html/virt-tar-in.1.html \
+         $<
+       touch $@
+
+virt-tar-out.1 $(top_builddir)/html/virt-tar-out.1.html: stamp-virt-tar-out.pod
+
+stamp-virt-tar-out.pod: virt-tar-out.pod
+       $(top_srcdir)/podwrapper.sh \
+         --man virt-tar-out.1 \
+         --html $(top_builddir)/html/virt-tar-out.1.html \
+         $<
+       touch $@
 
 # Bash completion script.