Fix networking in the appliance.
[libguestfs.git] / fish / Makefile.am
index e1e8833..91094df 100644 (file)
@@ -22,7 +22,10 @@ bin_PROGRAMS = guestfish
 generator_built = \
        cmds.c \
        completion.c \
-       guestfish-actions.pod
+       guestfish-actions.pod \
+       guestfish-commands.pod \
+       prepopts.h \
+       prepopts.c
 
 BUILT_SOURCES = \
        $(generator_built) \
@@ -38,20 +41,28 @@ EXTRA_DIST = \
 guestfish_SOURCES = \
        $(generator_built) \
        alloc.c \
+       copy.c \
        destpaths.c \
        echo.c \
        edit.c \
        fish.c \
        fish.h \
        glob.c \
+       hexedit.c \
        inspect.c \
        lcd.c \
        man.c \
        more.c \
        prep.c \
+       prep_disk.c \
+       prep_part.c \
+       prep_fs.c \
+       prep_lv.c \
+       prep_boot.c \
        progress.c \
        rc.c \
        reopen.c \
+       rmsd.h \
        supported.c \
        tilde.c \
        time.c \
@@ -97,17 +108,18 @@ endif
 
 guestfish.static$(EXEEXT): $(guestfish_OBJECTS) $(guestfish_DEPENDENCIES)
        $(top_srcdir)/relink-static.sh \
-       $(guestfish_LINK) $(guestfish_OBJECTS) -static $(guestfish_LDADD) $(guestfish_LIBS) -lpcre -lhivex -lmagic -lz -lm
+       $(guestfish_LINK) $(guestfish_OBJECTS) -static $(guestfish_LDADD) $(guestfish_LIBS) -ltinfo -lpcre -lhivex -lmagic -lz -lm
 
 # Manual page.
-# guestfish-actions.pod is autogenerated.  There is no include
-# mechanism for POD, so we have to do it by hand.
+# guestfish-actions.pod and guestfish-commands.pod are autogenerated.
+# There is no include mechanism for POD, so we have to do it by hand.
 
 man_MANS = guestfish.1
 
-guestfish.1: guestfish.pod guestfish-actions.pod
+guestfish.1: guestfish.pod guestfish-actions.pod guestfish-commands.pod
        sed \
          -e '/@ACTIONS@/rguestfish-actions.pod' -e 's/@ACTIONS@//' \
+         -e '/@FISH_COMMANDS@/rguestfish-commands.pod' -e 's/@FISH_COMMANDS@//' \
          < $< | \
        $(POD2MAN) \
          --section 1 \