fish: Implement copy-in and copy-out commands.
[libguestfs.git] / fish / Makefile.am
index d817e6c..906d362 100644 (file)
@@ -1,5 +1,5 @@
 # libguestfs
-# Copyright (C) 2009 Red Hat Inc.
+# Copyright (C) 2009-2010 Red Hat Inc.
 #
 # This program is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
@@ -22,7 +22,9 @@ bin_PROGRAMS = guestfish
 generator_built = \
        cmds.c \
        completion.c \
-       guestfish-actions.pod
+       guestfish-actions.pod \
+       prepopts.h \
+       prepopts.c
 
 BUILT_SOURCES = \
        $(generator_built) \
@@ -32,23 +34,37 @@ BUILT_SOURCES = \
 EXTRA_DIST = \
        $(BUILT_SOURCES) \
        rc_protocol.x \
-       guestfish.pod
+       guestfish.pod \
+       guestfish-bash-completion.sh
 
 guestfish_SOURCES = \
        $(generator_built) \
        alloc.c \
+       copy.c \
        destpaths.c \
        echo.c \
        edit.c \
        fish.c \
        fish.h \
        glob.c \
+       inspect.c \
        lcd.c \
+       man.c \
        more.c \
+       prep.c \
+       prep_disk.c \
+       prep_part.c \
+       prep_fs.c \
+       prep_lv.c \
+       prep_boot.c \
+       progress.c \
        rc.c \
        reopen.c \
+       rmsd.h \
+       supported.c \
        tilde.c \
-       time.c
+       time.c \
+       virt.c
 
 # This convenience library is solely to avoid compiler warnings
 # in its generated sources.
@@ -59,10 +75,14 @@ guestfish_CFLAGS = \
        -I$(top_srcdir)/src -I$(top_builddir)/src \
        -I$(top_srcdir)/fish -I$(top_builddir)/fish \
        -DGUESTFS_DEFAULT_PATH='"$(libdir)/guestfs"' \
+       -DLOCALEBASEDIR=\""$(datadir)/locale"\" \
        -I$(srcdir)/../gnulib/lib -I../gnulib/lib \
+       $(LIBVIRT_CFLAGS) $(LIBXML2_CFLAGS) \
        $(WARN_CFLAGS) $(WERROR_CFLAGS)
 
-guestfish_LDADD = $(top_builddir)/src/libguestfs.la $(LIBREADLINE)
+guestfish_LDADD = \
+       $(LIBVIRT_LIBS) $(LIBXML2_LIBS) \
+       $(top_builddir)/src/libguestfs.la $(LIBREADLINE) -lm
 
 # Make libguestfs use the convenience library.
 noinst_LTLIBRARIES = librc_protocol.la
@@ -82,6 +102,12 @@ rc_protocol.h: rc_protocol.x
        mv $@-t $@
 endif
 
+# Build a partly-static library (for the binary distribution).
+
+guestfish.static$(EXEEXT): $(guestfish_OBJECTS) $(guestfish_DEPENDENCIES)
+       $(top_srcdir)/relink-static.sh \
+       $(guestfish_LINK) $(guestfish_OBJECTS) -static $(guestfish_LDADD) $(guestfish_LIBS) -ltinfo -lpcre -lhivex -lmagic -lz -lm
+
 # Manual page.
 # guestfish-actions.pod is autogenerated.  There is no include
 # mechanism for POD, so we have to do it by hand.
@@ -98,3 +124,8 @@ guestfish.1: guestfish.pod guestfish-actions.pod
          --name "guestfish" \
          --release "$(PACKAGE_NAME)-$(PACKAGE_VERSION)" \
          > $@
+
+# Bash completion script.
+
+bashcompletiondir = $(sysconfdir)/bash_completion.d
+bashcompletion_DATA = guestfish-bash-completion.sh