avoid compiler warnings about unused vars in generated code
[libguestfs.git] / fish / Makefile.am
index dd79361..5bf3fbd 100644 (file)
@@ -20,6 +20,8 @@ bin_PROGRAMS = guestfish
 EXTRA_DIST = \
        rc_protocol.x
 
+CLEANFILES = rc_protocol.c rc_protocol.h
+
 guestfish_SOURCES = \
        alloc.c \
        cmds.c \
@@ -33,25 +35,38 @@ guestfish_SOURCES = \
        lcd.c \
        more.c \
        rc.c \
-       rc_protocol.c \
-       rc_protocol.h \
        reopen.c \
+       tilde.c \
        time.c
 
+# This convenience library is solely to avoid compiler warnings
+# in its generated sources.
+librc_protocol_la_SOURCES = rc_protocol.c
+librc_protocol_la_CFLAGS = -Wall -Wno-unused
+
 BUILT_SOURCES = \
        rc_protocol.c \
        rc_protocol.h
 
 guestfish_CFLAGS = \
-       -I$(top_srcdir)/src -I$(top_builddir)/src -Wall \
+       -I$(top_srcdir)/src -I$(top_builddir)/src \
+       -I$(top_srcdir)/fish -I$(top_builddir)/fish \
+       -Wall \
        -DGUESTFS_DEFAULT_PATH='"$(libdir)/guestfs"'
+
 guestfish_LDADD = $(top_builddir)/src/libguestfs.la $(LIBREADLINE)
 
+# Make libguestfs use the convenience library.
+noinst_LTLIBRARIES = librc_protocol.la
+guestfish_LDADD += librc_protocol.la
+
 if HAVE_RPCGEN
 rc_protocol.c: rc_protocol.x
-       rm -f $@-t
+       rm -f $@-t $@-t2
        $(RPCGEN) -c -o $@-t $<
-       mv $@-t $@
+       sed 's,\.\./\.\./fish/,,' < $@-t > $@-t2
+       rm $@-t
+       mv $@-t2 $@
 
 rc_protocol.h: rc_protocol.x
        rm -f $@-t