daemon: debug segv correct use of dereferencing NULL.
[libguestfs.git] / fish / Makefile.am
index 22aaf4c..2624a7d 100644 (file)
@@ -13,7 +13,7 @@
 #
 # You should have received a copy of the GNU General Public License
 # along with this program; if not, write to the Free Software
-# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
 
 include $(top_srcdir)/subdir-rules.mk
 
@@ -30,6 +30,8 @@ generator_built = \
        cmds.c \
        cmds_gperf.gperf \
        completion.c \
+       event-names.c \
+       fish-cmds.h \
        guestfish-actions.pod \
        guestfish-commands.pod \
        prepopts.h \
@@ -43,6 +45,7 @@ BUILT_SOURCES = \
 
 EXTRA_DIST = \
        $(BUILT_SOURCES) \
+       $(TESTS) \
        rc_protocol.x \
        guestfish.pod \
        guestfish-bash-completion.sh \
@@ -56,16 +59,18 @@ EXTRA_DIST = \
        virt-tar-in.pod \
        virt-tar-out.pod
 
-# These source files (all related to option parsing) are shared
-# between guestfish and guestmount.  Keep a convenient list here just
-# so we know which ones are shared.  These files must not include
-# other guestfish files.
+# These source files (mostly related to option parsing) are shared
+# between guestfish, guestmount and some other virt tools.  Keep a
+# convenient list here just so we know which ones are shared.  These
+# files must not include other guestfish files.
 SHARED_SOURCE_FILES = \
        config.c \
        inspect.c \
        keys.c \
        options.h \
        options.c \
+       progress.h \
+       progress.c \
        virt.c
 
 guestfish_SOURCES = \
@@ -78,6 +83,7 @@ guestfish_SOURCES = \
        display.c \
        echo.c \
        edit.c \
+       events.c \
        fish.c \
        fish.h \
        glob.c \
@@ -92,10 +98,8 @@ guestfish_SOURCES = \
        prep_fs.c \
        prep_lv.c \
        prep_boot.c \
-       progress.c \
        rc.c \
        reopen.c \
-       rmsd.h \
        setenv.c \
        supported.c \
        tilde.c \
@@ -138,7 +142,7 @@ if HAVE_RPCGEN
 rc_protocol.c: rc_protocol.x
        rm -f $@-t $@-t2
        $(RPCGEN) -c -o $@-t $<
-       sed 's,\.\./\.\./fish/,,' < $@-t > $@-t2
+       sed 's,\.\./\(\.\./\)*fish,.,' < $@-t > $@-t2
        rm $@-t
        mv $@-t2 $@
 
@@ -170,18 +174,18 @@ noinst_DATA = \
 guestfish.1 $(top_builddir)/html/guestfish.1.html: stamp-guestfish.pod
 
 stamp-guestfish.pod: guestfish.pod guestfish-actions.pod guestfish-commands.pod
-       $(top_srcdir)/podwrapper.sh \
+       $(top_builddir)/podwrapper.sh \
          --man guestfish.1 \
          --html $(top_builddir)/html/guestfish.1.html \
-         --insert guestfish-actions.pod:@ACTIONS@ \
-         --insert guestfish-commands.pod:@FISH_COMMANDS@ \
+         --insert $(srcdir)/guestfish-actions.pod:@ACTIONS@ \
+         --insert $(srcdir)/guestfish-commands.pod:@FISH_COMMANDS@ \
          $<
        touch $@
 
 virt-copy-in.1 $(top_builddir)/html/virt-copy-in.1.html: stamp-virt-copy-in.pod
 
 stamp-virt-copy-in.pod: virt-copy-in.pod
-       $(top_srcdir)/podwrapper.sh \
+       $(top_builddir)/podwrapper.sh \
          --man virt-copy-in.1 \
          --html $(top_builddir)/html/virt-copy-in.1.html \
          $<
@@ -190,7 +194,7 @@ stamp-virt-copy-in.pod: virt-copy-in.pod
 virt-copy-out.1 $(top_builddir)/html/virt-copy-out.1.html: stamp-virt-copy-out.pod
 
 stamp-virt-copy-out.pod: virt-copy-out.pod
-       $(top_srcdir)/podwrapper.sh \
+       $(top_builddir)/podwrapper.sh \
          --man virt-copy-out.1 \
          --html $(top_builddir)/html/virt-copy-out.1.html \
          $<
@@ -199,7 +203,7 @@ stamp-virt-copy-out.pod: virt-copy-out.pod
 virt-tar-in.1 $(top_builddir)/html/virt-tar-in.1.html: stamp-virt-tar-in.pod
 
 stamp-virt-tar-in.pod: virt-tar-in.pod
-       $(top_srcdir)/podwrapper.sh \
+       $(top_builddir)/podwrapper.sh \
          --man virt-tar-in.1 \
          --html $(top_builddir)/html/virt-tar-in.1.html \
          $<
@@ -208,7 +212,7 @@ stamp-virt-tar-in.pod: virt-tar-in.pod
 virt-tar-out.1 $(top_builddir)/html/virt-tar-out.1.html: stamp-virt-tar-out.pod
 
 stamp-virt-tar-out.pod: virt-tar-out.pod
-       $(top_srcdir)/podwrapper.sh \
+       $(top_builddir)/podwrapper.sh \
          --man virt-tar-out.1 \
          --html $(top_builddir)/html/virt-tar-out.1.html \
          $<
@@ -223,3 +227,28 @@ toolsconf_DATA = libguestfs-tools.conf
 
 bashcompletiondir = $(sysconfdir)/bash_completion.d
 bashcompletion_DATA = guestfish-bash-completion.sh
+
+# Tests.
+
+random_val := $(shell awk 'BEGIN{srand(); print 1+int(255*rand())}' < /dev/null)
+
+TESTS_ENVIRONMENT = \
+       MALLOC_PERTURB_=$(random_val) \
+       LD_LIBRARY_PATH=$(top_builddir)/src/.libs \
+       LIBGUESTFS_PATH=$(top_builddir)/appliance \
+       TMPDIR=$(top_builddir)
+
+TESTS = \
+       test-add-domain.sh \
+       test-copy.sh \
+       test-find0.sh \
+       test-guestfish-a.sh \
+       test-guestfish-d.sh \
+       test-guestfish-escapes.sh \
+       test-guestfish-events.sh \
+       test-guestfish-tilde.sh \
+       test-read_file.sh \
+       test-remote.sh \
+       test-reopen.sh \
+       test-stringlist.sh \
+       test-upload-to-dir.sh