Fix rpcgen post-processing for out-of-tree builds
[libguestfs.git] / fish / Makefile.am
index 311da89..16a29b0 100644 (file)
@@ -1,5 +1,5 @@
 # libguestfs
-# Copyright (C) 2009-2010 Red Hat Inc.
+# Copyright (C) 2009-2011 Red Hat Inc.
 #
 # This program is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
@@ -13,7 +13,7 @@
 #
 # You should have received a copy of the GNU General Public License
 # along with this program; if not, write to the Free Software
-# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
 
 include $(top_srcdir)/subdir-rules.mk
 
@@ -30,6 +30,7 @@ generator_built = \
        cmds.c \
        cmds_gperf.gperf \
        completion.c \
+       fish-cmds.h \
        guestfish-actions.pod \
        guestfish-commands.pod \
        prepopts.h \
@@ -46,6 +47,7 @@ EXTRA_DIST = \
        rc_protocol.x \
        guestfish.pod \
        guestfish-bash-completion.sh \
+       libguestfs-tools.conf \
        virt-copy-in \
        virt-copy-out \
        virt-tar-in \
@@ -55,15 +57,18 @@ EXTRA_DIST = \
        virt-tar-in.pod \
        virt-tar-out.pod
 
-# These source files (all related to option parsing) are shared
-# between guestfish and guestmount.  Keep a convenient list here just
-# so we know which ones are shared.  These files must not include
-# other guestfish files.
+# These source files (mostly related to option parsing) are shared
+# between guestfish, guestmount and some other virt tools.  Keep a
+# convenient list here just so we know which ones are shared.  These
+# files must not include other guestfish files.
 SHARED_SOURCE_FILES = \
+       config.c \
        inspect.c \
        keys.c \
        options.h \
        options.c \
+       progress.h \
+       progress.c \
        virt.c
 
 guestfish_SOURCES = \
@@ -73,6 +78,7 @@ guestfish_SOURCES = \
        cmds_gperf.h \
        copy.c \
        destpaths.c \
+       display.c \
        echo.c \
        edit.c \
        fish.c \
@@ -89,18 +95,17 @@ guestfish_SOURCES = \
        prep_fs.c \
        prep_lv.c \
        prep_boot.c \
-       progress.c \
        rc.c \
        reopen.c \
-       rmsd.h \
+       setenv.c \
        supported.c \
        tilde.c \
        time.c
 
-# This convenience library is solely to avoid compiler warnings
-# in its generated sources.
-librc_protocol_la_SOURCES = rc_protocol.c
-librc_protocol_la_CFLAGS = -Wall -Wno-unused
+# This convenience library is solely to compile its generated sources with
+# custom flags.
+librc_protocol_la_SOURCES = rc_protocol.c rc_protocol.h
+librc_protocol_la_CFLAGS = -Wall -Wno-unused -fno-strict-aliasing
 
 # Build the command lookup perfect hash code.  The generated code has
 # lots of warnings so we must compile it in a separate mini-library.
@@ -113,15 +118,18 @@ cmds_gperf.c: cmds_gperf.gperf
        mv $@-t $@
 
 guestfish_CFLAGS = \
+       -DGUESTFS_WARN_DEPRECATED=1 \
        -I$(top_srcdir)/src -I$(top_builddir)/src \
        -I$(top_srcdir)/fish -I$(top_builddir)/fish \
-       -DGUESTFS_DEFAULT_PATH='"$(libdir)/guestfs"' \
        -DLOCALEBASEDIR=\""$(datadir)/locale"\" \
        -I$(srcdir)/../gnulib/lib -I../gnulib/lib \
-       $(WARN_CFLAGS) $(WERROR_CFLAGS)
+       $(WARN_CFLAGS) $(WERROR_CFLAGS) \
+       $(LIBCONFIG_CFLAGS)
 
 guestfish_LDADD = \
-       $(top_builddir)/src/libguestfs.la $(LIBREADLINE) -lm
+       $(LIBCONFIG_LIBS) \
+       $(LIBREADLINE) \
+       $(top_builddir)/src/libguestfs.la -lm
 
 # Make guestfish use the convenience libraries.
 noinst_LTLIBRARIES = libcmds.la librc_protocol.la
@@ -131,7 +139,7 @@ if HAVE_RPCGEN
 rc_protocol.c: rc_protocol.x
        rm -f $@-t $@-t2
        $(RPCGEN) -c -o $@-t $<
-       sed 's,\.\./\.\./fish/,,' < $@-t > $@-t2
+       sed 's,\.\./\(\.\./\)*fish,.,' < $@-t > $@-t2
        rm $@-t
        mv $@-t2 $@
 
@@ -163,18 +171,18 @@ noinst_DATA = \
 guestfish.1 $(top_builddir)/html/guestfish.1.html: stamp-guestfish.pod
 
 stamp-guestfish.pod: guestfish.pod guestfish-actions.pod guestfish-commands.pod
-       $(top_srcdir)/podwrapper.sh \
+       $(top_builddir)/podwrapper.sh \
          --man guestfish.1 \
          --html $(top_builddir)/html/guestfish.1.html \
-         --insert guestfish-actions.pod:@ACTIONS@ \
-         --insert guestfish-commands.pod:@FISH_COMMANDS@ \
+         --insert $(srcdir)/guestfish-actions.pod:@ACTIONS@ \
+         --insert $(srcdir)/guestfish-commands.pod:@FISH_COMMANDS@ \
          $<
        touch $@
 
 virt-copy-in.1 $(top_builddir)/html/virt-copy-in.1.html: stamp-virt-copy-in.pod
 
 stamp-virt-copy-in.pod: virt-copy-in.pod
-       $(top_srcdir)/podwrapper.sh \
+       $(top_builddir)/podwrapper.sh \
          --man virt-copy-in.1 \
          --html $(top_builddir)/html/virt-copy-in.1.html \
          $<
@@ -183,7 +191,7 @@ stamp-virt-copy-in.pod: virt-copy-in.pod
 virt-copy-out.1 $(top_builddir)/html/virt-copy-out.1.html: stamp-virt-copy-out.pod
 
 stamp-virt-copy-out.pod: virt-copy-out.pod
-       $(top_srcdir)/podwrapper.sh \
+       $(top_builddir)/podwrapper.sh \
          --man virt-copy-out.1 \
          --html $(top_builddir)/html/virt-copy-out.1.html \
          $<
@@ -192,7 +200,7 @@ stamp-virt-copy-out.pod: virt-copy-out.pod
 virt-tar-in.1 $(top_builddir)/html/virt-tar-in.1.html: stamp-virt-tar-in.pod
 
 stamp-virt-tar-in.pod: virt-tar-in.pod
-       $(top_srcdir)/podwrapper.sh \
+       $(top_builddir)/podwrapper.sh \
          --man virt-tar-in.1 \
          --html $(top_builddir)/html/virt-tar-in.1.html \
          $<
@@ -201,12 +209,17 @@ stamp-virt-tar-in.pod: virt-tar-in.pod
 virt-tar-out.1 $(top_builddir)/html/virt-tar-out.1.html: stamp-virt-tar-out.pod
 
 stamp-virt-tar-out.pod: virt-tar-out.pod
-       $(top_srcdir)/podwrapper.sh \
+       $(top_builddir)/podwrapper.sh \
          --man virt-tar-out.1 \
          --html $(top_builddir)/html/virt-tar-out.1.html \
          $<
        touch $@
 
+# libguestfs tools config file.
+
+toolsconfdir = $(sysconfdir)
+toolsconf_DATA = libguestfs-tools.conf
+
 # Bash completion script.
 
 bashcompletiondir = $(sysconfdir)/bash_completion.d