Move guestfs(3) and guestfish(1) man pages into subdirectories.
[libguestfs.git] / fish / Makefile.am
index 795952a..1652c54 100644 (file)
@@ -21,7 +21,8 @@ bin_PROGRAMS = guestfish
 
 generator_built = \
        cmds.c \
-       completion.c
+       completion.c \
+       guestfish-actions.pod
 
 BUILT_SOURCES = \
        $(generator_built) \
@@ -79,3 +80,20 @@ rc_protocol.h: rc_protocol.x
        $(RPCGEN) -h -o $@-t $<
        mv $@-t $@
 endif
+
+# Manual page.
+# guestfish-actions.pod is autogenerated.  There is no include
+# mechanism for POD, so we have to do it by hand.
+
+man_MANS = guestfish.1
+
+guestfish.1: guestfish.pod guestfish-actions.pod
+       sed \
+         -e '/@ACTIONS@/rguestfish-actions.pod' -e 's/@ACTIONS@//' \
+         < $< | \
+       $(POD2MAN) \
+         --section 1 \
+         -c "Virtualization Support" \
+         --name "guestfish" \
+         --release "$(PACKAGE_NAME)-$(PACKAGE_VERSION)" \
+         > $@