extra tests: Test virt-sparsify.
[libguestfs.git] / extratests / Makefile.am
index 3b46ae8..66aefaf 100644 (file)
@@ -47,6 +47,7 @@ extra-tests: \
        test-tools-internal \
        test-tools-real \
        test-resize \
+       test-sparsify \
        test-capitests \
        test-ocaml
 
@@ -102,12 +103,15 @@ test-tools-real:
 test-resize:
        $(MAKE) -C ../resize VG="$(VG)" check
 
+# Run virt-sparsify tests under valgrind.
+test-sparsify:
+       $(MAKE) -C ../sparsify VG="$(VG)" check
+
 # XXX Not tested:
 # ../clone/virt-sysprep
 # ../edit/virt-edit
 # ../edit/virt-edit -e
 # ../fuse/guestmount
-# ../sparsify/virt-sparsify (OCaml)
 # ../tools/virt-win-reg (Perl)
 # ../tools/virt-make-fs (Perl)