Move virt tools (virt-cat, virt-edit etc) into tools/ subdirectory.
[libguestfs.git] / edit / Makefile.am
diff --git a/edit/Makefile.am b/edit/Makefile.am
deleted file mode 100644 (file)
index 6afdd62..0000000
+++ /dev/null
@@ -1,45 +0,0 @@
-# libguestfs virt-edit
-# Copyright (C) 2009 Red Hat Inc.
-#
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2 of the License, or
-# (at your option) any later version.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
-# GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
-
-EXTRA_DIST = \
-       run-edit-locally \
-       virt-edit
-
-if HAVE_EDIT
-
-bin_SCRIPTS = virt-edit
-man_MANS = virt-edit.1
-
-noinst_DATA = $(top_builddir)/html/virt-edit.1.html
-
-virt-edit.1: virt-edit
-       $(POD2MAN) \
-         --section 1 \
-         -c "Virtualization Support" \
-         --release "$(PACKAGE_NAME)-$(PACKAGE_VERSION)" \
-         $< > $@-t && mv $@-t $@
-
-$(top_builddir)/html/virt-edit.1.html: virt-edit
-       mkdir -p $(top_builddir)/html
-       cd $(top_builddir) && pod2html \
-         --css 'pod.css' \
-         --title 'virt-edit, edit a file in a virtual machine' \
-         --htmldir html \
-         --outfile html/virt-edit.1.html \
-         edit/$<
-
-endif