debian: Build libguestfs-ocaml and libguestfs-ocaml-dev subpackages.
[libguestfs.git] / debian / rules
index 89a93d8..01b8329 100755 (executable)
@@ -1,5 +1,7 @@
 #!/usr/bin/make -f
 
+export DH_VERBOSE=1
+
 DEB_PYTHON_SYSTEM=pysupport
 DEB_DH_INSTALL_SOURCEDIR = debian/tmp
 DEB_VENDOR=$(shell dpkg-vendor --query vendor)
@@ -10,6 +12,7 @@ DEB_BUILD_OPTIONS=nocheck
 include /usr/share/cdbs/1/rules/debhelper.mk
 include /usr/share/cdbs/1/class/autotools.mk
 include /usr/share/cdbs/1/class/python-distutils.mk
+include /usr/share/cdbs/1/rules/ocaml.mk
 
 DEB_CONFIGURE_EXTRA_FLAGS := \
        --with-java-home=no \
@@ -17,6 +20,7 @@ DEB_CONFIGURE_EXTRA_FLAGS := \
        --disable-haskell \
        --disable-php \
        --with-readline \
+       --enable-install-daemon \
        --with-python-installdir=/usr/share/pyshared
 
 DEB_DBG_PACKAGES = libguestfs0-dbg