Augeas is now completely optional.
[libguestfs.git] / daemon / configure.ac
index 6cf4c0f..a91db6d 100644 (file)
@@ -46,13 +46,16 @@ test "x$U" != "x" && AC_MSG_ERROR([Compiler not ANSI compliant])
 
 AC_PROG_CC_C_O
 
-dnl Check for Augeas.
-AC_CHECK_LIB([augeas],[aug_match],,[
-       AC_MSG_ERROR([Augeas library not found])
-       ])
-
-dnl Check for functions not available in earlier versions of Augeas.
-AC_CHECK_FUNCS([aug_load aug_defvar aug_defnode])
+dnl Check for Augeas (now optional).
+AC_CHECK_LIB([augeas],[aug_match],[
+       LIBS="-laugeas $LIBS"
+       have_augeas=yes
+       dnl Check for functions not available in earlier versions of Augeas.
+       AC_CHECK_FUNCS([aug_load aug_defvar aug_defnode])
+       ],[have_augeas=no])
+if test "x$have_augeas" = "xyes"; then
+       AC_DEFINE([HAVE_AUGEAS],[1],[Define to 1 if you have Augeas])
+fi
 
 dnl Check for XDR library.
 AC_CHECK_LIB([portablexdr],[xdrmem_create],[],[