daemon/Win32: provide htonl, htons, ntohl, ntohs functions.
[libguestfs.git] / daemon / configure.ac
index d1a9b0f..1d335b1 100644 (file)
@@ -170,8 +170,9 @@ AC_CHECK_LIB([portablexdr],[xdrmem_create],[],[
 
 dnl Functions which may not be available in older distributions.
 AC_CHECK_FUNCS([\
-        futimens \
         getxattr \
+        htonl \
+        htons \
         inotify_init1 \
         lgetxattr \
         listxattr \
@@ -179,9 +180,12 @@ AC_CHECK_FUNCS([\
         lsetxattr \
         lremovexattr \
         mknod \
+        ntohl \
+        ntohs \
         posix_fallocate \
         removexattr \
         setxattr \
+        statvfs \
         sync])
 
 dnl Headers.
@@ -189,6 +193,7 @@ AC_CHECK_HEADERS([\
         attr/xattr.h \
         printf.h \
         sys/inotify.h \
+        sys/statvfs.h \
         sys/xattr.h \
         windows.h])