daemon/Win32: provide htonl, htons, ntohl, ntohs functions.
[libguestfs.git] / daemon / configure.ac
index 92776c2..1d335b1 100644 (file)
@@ -124,6 +124,12 @@ test "x$U" != "x" && AC_MSG_ERROR([Compiler not ANSI compliant])
 
 AM_PROG_CC_C_O
 
+dnl If the host is Windows, define _WIN32_WINNT to a suitable value.
+AC_CANONICAL_HOST
+case $host in
+     *mingw*|*cygwin*|*win32*) CFLAGS="$CFLAGS -D_WIN32_WINNT=0x0500" ;;
+esac
+
 dnl Check support for 64 bit file offsets.
 AC_SYS_LARGEFILE
 
@@ -133,7 +139,7 @@ AC_STRUCT_DIRENT_D_TYPE
 dnl Check if stat has the required fields.
 AC_STRUCT_ST_BLOCKS
 AC_CHECK_MEMBER([struct stat.st_blksize],[
-       AC_DEFINE([HAVE_STRUCT_STAT_ST_BLKSIZE],[1],[Define to 1 if 'st_blksize' is a member of 'struct stat'])])
+        AC_DEFINE([HAVE_STRUCT_STAT_ST_BLKSIZE],[1],[Define to 1 if 'st_blksize' is a member of 'struct stat'])])
 
 dnl Check for Augeas (now optional).
 AC_CHECK_LIB([augeas],[aug_match],[
@@ -164,27 +170,32 @@ AC_CHECK_LIB([portablexdr],[xdrmem_create],[],[
 
 dnl Functions which may not be available in older distributions.
 AC_CHECK_FUNCS([\
-       futimens \
-       getxattr \
-       inotify_init1 \
-       lgetxattr \
-       listxattr \
-       llistxattr \
-       lsetxattr \
-       lremovexattr \
-       mknod \
-       removexattr \
-       setxattr])
+        getxattr \
+        htonl \
+        htons \
+        inotify_init1 \
+        lgetxattr \
+        listxattr \
+        llistxattr \
+        lsetxattr \
+        lremovexattr \
+        mknod \
+        ntohl \
+        ntohs \
+        posix_fallocate \
+        removexattr \
+        setxattr \
+        statvfs \
+        sync])
 
 dnl Headers.
 AC_CHECK_HEADERS([\
-       attr/xattr.h \
-       netdb.h \
-       printf.h \
-       sys/inotify.h \
-       sys/select.h \
-       sys/wait.h \
-       sys/xattr.h])
+        attr/xattr.h \
+        printf.h \
+        sys/inotify.h \
+        sys/statvfs.h \
+        sys/xattr.h \
+        windows.h])
 
 dnl For modified printf, we need glibc either (old-style)
 dnl register_printf_function or (new-style) register_printf_specifier.