daemon: use gnulib
[libguestfs.git] / daemon / Makefile.am
index 141dfad..43cc752 100644 (file)
@@ -17,6 +17,8 @@
 
 ACLOCAL_AMFLAGS = -I m4
 
+SUBDIRS = lib tests .
+
 noinst_PROGRAMS = guestfsd
 guestfsd_SOURCES = \
        actions.h \
@@ -35,15 +37,19 @@ guestfsd_SOURCES = \
        dropcaches.c \
        du.c \
        ext2.c \
+       fallocate.c \
        file.c \
        find.c \
        fsck.c \
        glob.c \
+       grep.c \
        grub.c \
        guestfsd.c \
        headtail.c \
        hexdump.c \
        initrd.c \
+       inotify.c \
+       link.c \
        ls.c \
        lvm.c \
        mknod.c \
@@ -53,6 +59,7 @@ guestfsd_SOURCES = \
        pingdaemon.c \
        proto.c \
        readdir.c \
+       realpath.c \
        scrub.c \
        sfdisk.c \
        sleep.c \
@@ -65,9 +72,12 @@ guestfsd_SOURCES = \
        umask.c \
        upload.c \
        wc.c \
+       xattr.c \
        zero.c \
        zerofree.c \
-       ../src/guestfs_protocol.h \
-       ../src/guestfs_protocol.c
+       $(top_builddir)/../src/guestfs_protocol.h \
+       $(top_builddir)/../src/guestfs_protocol.c
 
+AM_CPPFLAGS = -I$(srcdir)/lib -Ilib
 guestfsd_CFLAGS = -Wall
+LDADD = lib/libgnu.a