Add interface to Linux 'inotify' API.
[libguestfs.git] / daemon / Makefile.am
index d6ae6c3..024c097 100644 (file)
@@ -29,29 +29,51 @@ guestfsd_SOURCES = \
        daemon.h \
        debug.c \
        devsparts.c \
+       df.c \
        dir.c \
        dmesg.c \
        dropcaches.c \
+       du.c \
        ext2.c \
+       fallocate.c \
        file.c \
+       find.c \
        fsck.c \
+       glob.c \
+       grep.c \
        grub.c \
        guestfsd.c \
+       headtail.c \
        hexdump.c \
+       initrd.c \
+       inotify.c \
+       link.c \
        ls.c \
        lvm.c \
+       mknod.c \
        mount.c \
+       names.c \
+       ntfs.c \
        pingdaemon.c \
        proto.c \
+       readdir.c \
+       realpath.c \
+       scrub.c \
+       sfdisk.c \
+       sleep.c \
        stat.c \
        strings.c \
        stubs.c \
+       swap.c \
        sync.c \
        tar.c \
+       umask.c \
        upload.c \
+       wc.c \
+       xattr.c \
        zero.c \
        zerofree.c \
-       ../src/guestfs_protocol.h \
-       ../src/guestfs_protocol.c
+       $(top_builddir)/../src/guestfs_protocol.h \
+       $(top_builddir)/../src/guestfs_protocol.c
 
 guestfsd_CFLAGS = -Wall