inspect: Add support for Linux Mint and Mandriva.
[libguestfs.git] / cat / Makefile.am
index 6b9a1bb..63064e6 100644 (file)
@@ -1,5 +1,5 @@
-# libguestfs virt-cat
-# Copyright (C) 2009 Red Hat Inc.
+# libguestfs virt-cat.
+# Copyright (C) 2010 Red Hat Inc.
 #
 # This program is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
 # along with this program; if not, write to the Free Software
 # Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
 
+include $(top_srcdir)/subdir-rules.mk
+
 EXTRA_DIST = \
        run-cat-locally \
-       virt-cat
+       test-virt-cat.sh \
+       virt-cat.pod
+
+bin_PROGRAMS = virt-cat
+
+SHARED_SOURCE_FILES = \
+       ../fish/inspect.c \
+       ../fish/keys.c \
+       ../fish/options.h \
+       ../fish/options.c \
+       ../fish/virt.c
+
+virt_cat_SOURCES = \
+       $(SHARED_SOURCE_FILES) \
+       virt-cat.c
+
+virt_cat_CFLAGS = \
+       -I$(top_srcdir)/src -I$(top_builddir)/src \
+       -I$(top_srcdir)/fish \
+       -I$(srcdir)/../gnulib/lib -I../gnulib/lib \
+       -DLOCALEBASEDIR=\""$(datadir)/locale"\" \
+       $(WARN_CFLAGS) $(WERROR_CFLAGS)
 
-if HAVE_CAT
+virt_cat_LDADD = \
+       $(top_builddir)/src/libguestfs.la \
+       ../gnulib/lib/libgnu.la
 
-bin_SCRIPTS = virt-cat
+# Manual pages and HTML files for the website.
 man_MANS = virt-cat.1
 
 noinst_DATA = $(top_builddir)/html/virt-cat.1.html
 
-virt-cat.1: virt-cat
+virt-cat.1: virt-cat.pod
        $(POD2MAN) \
          --section 1 \
          -c "Virtualization Support" \
          --release "$(PACKAGE_NAME)-$(PACKAGE_VERSION)" \
          $< > $@-t && mv $@-t $@
 
-$(top_builddir)/html/virt-cat.1.html: virt-cat
+$(top_builddir)/html/virt-cat.1.html: virt-cat.pod
        mkdir -p $(top_builddir)/html
        cd $(top_builddir) && pod2html \
          --css 'pod.css' \
-         --title 'virt-cat, display a file in a virtual machine' \
          --htmldir html \
-         --outfile html/virt-cat.1.html \
-         cat/$<
+         --outfile html/$@ \
+         $(abs_srcdir)/$<
+
+# Tests.
+
+random_val := $(shell awk 'BEGIN{srand(); print 1+int(255*rand())}' < /dev/null)
+
+TESTS_ENVIRONMENT = \
+       MALLOC_PERTURB_=$(random_val) \
+       LD_LIBRARY_PATH=$(top_builddir)/src/.libs \
+       LIBGUESTFS_PATH=$(top_builddir)/appliance
+
+TESTS = test-virt-cat.sh
+
+# Build a partly-static library (for the binary distribution).
 
-endif
+virt-cat.static$(EXEEXT): $(virt_cat_OBJECTS) $(virt_cat_DEPENDENCIES)
+       $(top_srcdir)/relink-static.sh \
+       $(virt_cat_LINK) $(virt_cat_OBJECTS) -static $(virt_cat_LDADD) $(virt_cat_LIBS) $(LIBVIRT_LIBS) $(LIBXML2_LIBS) -lpcre -lhivex -lmagic -lz -lm