capitests: Test guestfs_add_drive_opts with optional args from C.
[libguestfs.git] / capitests / Makefile.am
index 1374d9b..435b1ee 100644 (file)
@@ -27,12 +27,14 @@ check_PROGRAMS = \
        tests \
        test-command \
        test-create-handle \
        tests \
        test-command \
        test-create-handle \
-       test-config
+       test-config \
+       test-add-drive-opts
 
 TESTS = \
        tests \
        test-create-handle \
 
 TESTS = \
        tests \
        test-create-handle \
-       test-config
+       test-config \
+       test-add-drive-opts
 TESTS_ENVIRONMENT = \
        SKIP_TEST_COMMAND=$(shell ldd test-command | grep -sq 'not a dynamic executable' || echo 1) \
        SKIP_TEST_COMMAND_LINES=$(shell ldd test-command | grep -sq 'not a dynamic executable' || echo 1) \
 TESTS_ENVIRONMENT = \
        SKIP_TEST_COMMAND=$(shell ldd test-command | grep -sq 'not a dynamic executable' || echo 1) \
        SKIP_TEST_COMMAND_LINES=$(shell ldd test-command | grep -sq 'not a dynamic executable' || echo 1) \
@@ -67,6 +69,13 @@ test_config_CFLAGS = \
 test_config_LDADD = \
        $(top_builddir)/src/libguestfs.la
 
 test_config_LDADD = \
        $(top_builddir)/src/libguestfs.la
 
+test_add_drive_opts_SOURCES = test-add-drive-opts.c
+test_add_drive_opts_CFLAGS = \
+       -I$(top_srcdir)/src -I$(top_builddir)/src \
+       $(WARN_CFLAGS) $(WERROR_CFLAGS)
+test_add_drive_opts_LDADD = \
+       $(top_builddir)/src/libguestfs.la
+
 # Run the tests under valgrind.
 
 valgrind:
 # Run the tests under valgrind.
 
 valgrind: