build: enable gcc warnings in capitests/ and ocaml/
[libguestfs.git] / capitests / Makefile.am
index 361c6a3..3b80c0e 100644 (file)
@@ -24,7 +24,8 @@ EXTRA_DIST = \
 check_PROGRAMS = tests test-command
 
 tests_SOURCES = tests.c
-tests_CFLAGS = -I$(top_srcdir)/src -I$(top_builddir)/src -Wall
+tests_CFLAGS = -I$(top_srcdir)/src -I$(top_builddir)/src \
+  $(WARN_CFLAGS) $(WERROR_CFLAGS)
 tests_LDADD = $(top_builddir)/src/libguestfs.la
 
 # Old version of e2fsprogs which didn't support UUIDs?