capitests: Test guestfs_last_errno call.
[libguestfs.git] / capitests / Makefile.am
index 435b1ee..1dded1e 100644 (file)
@@ -28,13 +28,15 @@ check_PROGRAMS = \
        test-command \
        test-create-handle \
        test-config \
-       test-add-drive-opts
+       test-add-drive-opts \
+       test-last-errno
 
 TESTS = \
        tests \
        test-create-handle \
        test-config \
-       test-add-drive-opts
+       test-add-drive-opts \
+       test-last-errno
 TESTS_ENVIRONMENT = \
        SKIP_TEST_COMMAND=$(shell ldd test-command | grep -sq 'not a dynamic executable' || echo 1) \
        SKIP_TEST_COMMAND_LINES=$(shell ldd test-command | grep -sq 'not a dynamic executable' || echo 1) \
@@ -76,6 +78,13 @@ test_add_drive_opts_CFLAGS = \
 test_add_drive_opts_LDADD = \
        $(top_builddir)/src/libguestfs.la
 
+test_last_errno_SOURCES = test-last-errno.c
+test_last_errno_CFLAGS = \
+       -I$(top_srcdir)/src -I$(top_builddir)/src \
+       $(WARN_CFLAGS) $(WERROR_CFLAGS)
+test_last_errno_LDADD = \
+       $(top_builddir)/src/libguestfs.la
+
 # Run the tests under valgrind.
 
 valgrind: