remove superflous debirf scripts
[libguestfs.git] / appliance / Makefile.am
index 883bda5..e2b0b31 100644 (file)
@@ -19,7 +19,13 @@ EXTRA_DIST = \
        make.sh update.sh supermin-split.sh supermin-make.sh \
        libguestfs-supermin-helper \
        kmod.whitelist \
-       kmod.whitelist.in
+       kmod.whitelist.in \
+       packagelist.in \
+       init \
+       debian/modules/install_kernel \
+       debian/modules/y0_install-guestfsd \
+       debian/modules/z99_final-cleanups \
+       debian/debirf.conf.in
 
 # Build the root filesystem (appliance).
 # Currently this is arch-dependent, so it seems like putting it in
@@ -52,12 +58,12 @@ endif
 # This is for building the normal appliance:
 $(INITRAMFSIMG) $(VMLINUZ): $(top_builddir)/initramfs/fakeroot.log
 
-$(top_builddir)/initramfs/fakeroot.log: make.sh kmod.whitelist
+$(top_builddir)/initramfs/fakeroot.log: make.sh kmod.whitelist packagelist
        -mv $(INITRAMFSIMG) $(INITRAMFSIMG).bak
        -mv $(VMLINUZ) $(VMLINUZ).bak
        if ! bash make.sh; then rm -f $@; exit 1; fi
 
-$(INITRAMFSIMG): $(top_builddir)/initramfs/fakeroot.log $(top_builddir)/daemon/guestfsd update.sh
+$(INITRAMFSIMG): $(top_builddir)/initramfs/fakeroot.log $(top_builddir)/daemon/guestfsd init update.sh
        rm -f $@
        bash update.sh
        touch $@
@@ -65,6 +71,10 @@ $(INITRAMFSIMG): $(top_builddir)/initramfs/fakeroot.log $(top_builddir)/daemon/g
 kmod.whitelist: kmod.whitelist.in
        grep -v '^[[:space:]]*$$' < $< | grep -v '^#' > $@
 
+packagelist: packagelist.in
+       cpp -undef -D$(DIST)=1 < $< | \
+       grep -v '^[[:space:]]*$$' | grep -v '^#' > $@
+
 # This is for building the supermin appliance.  It has to be enabled
 # specifically with './configure --enable-supermin'.  You really need
 # to read the README file.
@@ -74,7 +84,7 @@ if SUPERMIN
 # First we need to decide which files go in and out of the supermin
 # appliance.  This decision is made by 'supermin-split.sh'.
 $(SUPERMINFILES): supermin.incfiles
-supermin.incfiles: $(top_builddir)/initramfs/fakeroot.log supermin-split.sh
+supermin.incfiles: $(top_builddir)/initramfs/fakeroot.log $(top_builddir)/daemon/guestfsd supermin-split.sh
        rm -f supermin.incfiles $(SUPERMINFILES)
        bash supermin-split.sh
 
@@ -86,15 +96,19 @@ $(SUPERMINIMG): supermin.incfiles supermin-make.sh
 
 endif
 
-# This should rebuild the scripts if the input files change, although
-# it doesn't always seem to work.
-%.sh: %.sh.in
-       cd .. && ./config.status appliance/$@
-       chmod +x $@
-
-libguestfs-supermin-helper: libguestfs-supermin-helper.in
-       cd .. && ./config.status appliance/$@
-       chmod +x $@
+# Extra symlinks needed by the Debian appliance.
+debirf_symlinks = \
+       a0_prep-root \
+       z0_remove-aptitude \
+       z0_remove-locales \
+       z1_clean-root
+noinst_DATA = $(debirf_symlinks:%=debian/modules/%)
+$(debirf_symlinks:%=debian/modules/%): stamp-debirf-modules
+stamp-debirf-modules:
+       for f in $(debirf_symlinks); do \
+         ln -sf /usr/share/debirf/modules/$$f debian/modules/$$f; \
+       done
+       touch $@
 
 #----------------------------------------------------------------------
 # Extra rules for testing the appliance.
@@ -120,7 +134,7 @@ test-boot-realistic: emptydisk
          -m 384 \
          -kernel $(VMLINUZ) -initrd $(INITRAMFSIMG) \
          -hda emptydisk \
-         -append "console=ttyS0 guestfs=10.0.2.4:6666" \
+         -append "console=ttyS0 guestfs=10.0.2.4:6666 guestfs_rescue=1" \
          -nographic \
          -serial stdio \
          -net channel,6666:unix:/tmp/sock,server,nowait \