appliance: Put /init in a separate supermin appliance component.
[libguestfs.git] / appliance / Makefile.am
index 172f0cf..dec1c15 100644 (file)
@@ -43,12 +43,13 @@ fs_DATA += kmod.whitelist
 superminfs_DATA = \
        supermin.d/base.img \
        supermin.d/daemon.img \
+       supermin.d/init.img \
        supermin.d/hostfiles
 endif
 
 # Don't change these names - they must be the same as in '*.sh' scripts.
-INITRAMFSIMG = initramfs.$(REPO).$(host_cpu).img
-VMLINUZ = vmlinuz.$(REPO).$(host_cpu)
+INITRAMFSIMG = initramfs.$(host_cpu).img
+VMLINUZ = vmlinuz.$(host_cpu)
 
 # This is for building the normal appliance:
 $(INITRAMFSIMG) $(VMLINUZ): $(top_builddir)/initramfs/fakeroot.log
@@ -101,6 +102,14 @@ supermin.d/daemon.img: $(INITRAMFSIMG)
        (cd $(top_builddir)/initramfs && \
          echo -e "sbin\nsbin/guestfsd" | cpio --quiet -o -H newc ) > $@-t
        mv $@-t $@
+
+supermin.d/init.img: $(INITRAMFSIMG)
+       mkdir -p supermin.d
+       rm -f $@ $@-t
+       (cd $(top_builddir)/initramfs && \
+         echo -e "init\n" | cpio --quiet -o -H newc ) > $@-t
+       mv $@-t $@
+
 endif
 
 # Extra symlinks needed by the Debian appliance.