use 'stupid_simple' instead of 'nested' initramfs
[libguestfs.git] / appliance / Makefile.am
index 9de11cd..7abee80 100644 (file)
@@ -98,20 +98,18 @@ endif
 
 # Extra symlinks needed by the Debian appliance.
 debirf_symlinks = \
-       a0_motd \
        a0_prep-root \
-       network \
-       root-bashrc \
-       serial-terminal \
        z0_remove-aptitude \
        z0_remove-locales \
        z1_clean-root
 noinst_DATA = $(debirf_symlinks:%=debian/modules/%)
 $(debirf_symlinks:%=debian/modules/%): stamp-debirf-modules
 stamp-debirf-modules:
+       mkdir -p debian/modules
        for f in $(debirf_symlinks); do \
          ln -sf /usr/share/debirf/modules/$$f debian/modules/$$f; \
        done
+       touch $@
 
 #----------------------------------------------------------------------
 # Extra rules for testing the appliance.