RHEL 6: sr_mod.ko is needed for RHEL 6 to see CD-ROM devices (RHBZ#598807).
[libguestfs.git] / appliance / Makefile.am
index 72dfc71..2df8a2b 100644 (file)
@@ -21,7 +21,6 @@ EXTRA_DIST = \
        kmod.whitelist.in \
        packagelist.in \
        init \
-       debian/modules/install_kernel \
        debian/modules/y0_install-guestfsd \
        debian/modules/z99_final-cleanups \
        debian/debirf.conf.in \
@@ -91,6 +90,9 @@ stamp-supermin: $(INITRAMFSIMG)
        mkdir -p supermin.d
        rm -f $@ supermin.d/base.img supermin.d/hostfiles
        febootstrap-to-supermin $(top_builddir)/initramfs supermin.d/base.img supermin.d/hostfiles
+       if grep -q /usr/share/augeas/lenses supermin.d/hostfiles; then \
+               echo "./usr/share/augeas/lenses/*.aug" >> supermin.d/hostfiles; \
+       fi
        touch $@
 
 supermin.d/daemon.img: $(INITRAMFSIMG)
@@ -104,6 +106,7 @@ endif
 # Extra symlinks needed by the Debian appliance.
 debirf_symlinks = \
        a0_prep-root \
+       install-kernel \
        z0_remove-aptitude \
        z0_remove-locales \
        z1_clean-root