appliance: Remove repo from appliance filename (RHBZ#638901).
[libguestfs.git] / appliance / Makefile.am
index 74157b0..0abd698 100644 (file)
 # along with this program; if not, write to the Free Software
 # Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
 
+include $(top_srcdir)/subdir-rules.mk
+
 EXTRA_DIST = \
-       make.sh update.sh supermin-split.sh supermin-make.sh \
-       libguestfs-supermin-helper \
-       kmod.whitelist \
        kmod.whitelist.in \
        packagelist.in \
-       init
+       init \
+       debian/modules/y0_install-guestfsd \
+       debian/modules/z99_final-cleanups \
+       debian/debirf.conf.in \
+       make.sh.in
 
 # Build the root filesystem (appliance).
 # Currently this is arch-dependent, so it seems like putting it in
 # $(libdir) is best.  When we build cross-architecture filesystems we
 # should probably move them to $(datadir).
 fsdir = $(libdir)/guestfs
-fs_DATA = $(APPLIANCE_FILES)
+superminfsdir = $(libdir)/guestfs/supermin.d
 
 # These are the resulting output files from the whole process:
 #   VMLINUZ        kernel for the full appliance
 #   INITRAMFSIMG   initramfs (ie. root fs) for the full appliance
-# For details of the supermin appliance, read the README file:
-#   SUPERMINIMG    initramfs (ie. partial root fs) for the supermin appliance
-#   SUPERMINFILES  list of missing files (the ones we will pull out of the
-#                    host filesystem at runtime) in the supermin appliance
-APPLIANCE_FILES = $(INITRAMFSIMG) $(VMLINUZ)
+# For details of the supermin appliance, read the README file.
+fs_DATA = $(INITRAMFSIMG) $(VMLINUZ)
 if SUPERMIN
-APPLIANCE_FILES += $(SUPERMINIMG) $(SUPERMINFILES) kmod.whitelist
-bin_SCRIPTS = libguestfs-supermin-helper
+fs_DATA += kmod.whitelist
+superminfs_DATA = \
+       supermin.d/base.img \
+       supermin.d/daemon.img \
+       supermin.d/hostfiles
 endif
 
 # Don't change these names - they must be the same as in '*.sh' scripts.
-INITRAMFSIMG = initramfs.$(REPO).$(host_cpu).img
-VMLINUZ = vmlinuz.$(REPO).$(host_cpu)
-if SUPERMIN
-SUPERMINIMG = initramfs.$(REPO).$(host_cpu).supermin.img
-SUPERMINFILES = initramfs.$(REPO).$(host_cpu).supermin.hostfiles
-endif
+INITRAMFSIMG = initramfs.$(host_cpu).img
+VMLINUZ = vmlinuz.$(host_cpu)
 
 # This is for building the normal appliance:
 $(INITRAMFSIMG) $(VMLINUZ): $(top_builddir)/initramfs/fakeroot.log
 
-$(top_builddir)/initramfs/fakeroot.log: make.sh kmod.whitelist packagelist init
-       -mv $(INITRAMFSIMG) $(INITRAMFSIMG).bak
-       -mv $(VMLINUZ) $(VMLINUZ).bak
+$(top_builddir)/initramfs/fakeroot.log: make.sh kmod.whitelist packagelist
+       mv $(INITRAMFSIMG) $(INITRAMFSIMG).bak 2>/dev/null; :
+       mv $(VMLINUZ) $(VMLINUZ).bak 2>/dev/null; :
        if ! bash make.sh; then rm -f $@; exit 1; fi
 
-$(INITRAMFSIMG): $(top_builddir)/initramfs/fakeroot.log $(top_builddir)/daemon/guestfsd update.sh
+# This used to be a configure-generated file (as is update.sh still).
+# However config.status always touches the destination file, which
+# means the appliance got rebuilt too often.
+make.sh: make.sh.in
+       cd $(top_builddir) && \
+         ./config.status --file=appliance/$@-t:appliance/$<
+       chmod +x $@-t
+       mv $@-t $@
+
+$(INITRAMFSIMG): $(top_builddir)/initramfs/fakeroot.log $(top_builddir)/daemon/guestfsd init update.sh
        rm -f $@
        bash update.sh
        touch $@
@@ -68,7 +76,7 @@ kmod.whitelist: kmod.whitelist.in
        grep -v '^[[:space:]]*$$' < $< | grep -v '^#' > $@
 
 packagelist: packagelist.in
-       cpp -undef -DREDHAT=1 < $< | \
+       cpp -undef -D$(DIST)=1 < $< | \
        grep -v '^[[:space:]]*$$' | grep -v '^#' > $@
 
 # This is for building the supermin appliance.  It has to be enabled
@@ -77,66 +85,44 @@ packagelist: packagelist.in
 
 if SUPERMIN
 
-# First we need to decide which files go in and out of the supermin
-# appliance.  This decision is made by 'supermin-split.sh'.
-$(SUPERMINFILES): supermin.incfiles
-supermin.incfiles: $(top_builddir)/initramfs/fakeroot.log $(top_builddir)/daemon/guestfsd supermin-split.sh
-       rm -f supermin.incfiles $(SUPERMINFILES)
-       bash supermin-split.sh
-
-# Second we need to create a supermin appliance with just the included
-# files (leaving out the host files, which we'll add back at runtime).
-$(SUPERMINIMG): supermin.incfiles supermin-make.sh
-       rm -f $@
-       bash supermin-make.sh
+supermin.d/base.img supermin.d/hostfiles: stamp-supermin
+stamp-supermin: $(INITRAMFSIMG)
+       mkdir -p supermin.d
+       rm -f $@ supermin.d/base.img supermin.d/hostfiles
+       febootstrap-to-supermin $(top_builddir)/initramfs supermin.d/base.img supermin.d/hostfiles
+       if grep -q /usr/share/augeas/lenses supermin.d/hostfiles; then \
+               echo "./usr/share/augeas/lenses/*.aug" >> supermin.d/hostfiles; \
+       fi
+       touch $@
 
+supermin.d/daemon.img: $(INITRAMFSIMG)
+       mkdir -p supermin.d
+       rm -f $@ $@-t
+       (cd $(top_builddir)/initramfs && \
+         echo -e "sbin\nsbin/guestfsd" | cpio --quiet -o -H newc ) > $@-t
+       mv $@-t $@
 endif
 
-# This should rebuild the scripts if the input files change, although
-# it doesn't always seem to work.
-%.sh: %.sh.in
-       cd .. && ./config.status appliance/$@
-       chmod +x $@
-
-libguestfs-supermin-helper: libguestfs-supermin-helper.in
-       cd .. && ./config.status appliance/$@
-       chmod +x $@
-
-#----------------------------------------------------------------------
-# Extra rules for testing the appliance.
-
-# Test-boot the appliance.
-
-test-boot: emptydisk
-       qemu-system-$(host_cpu) \
-         -m 384 \
-         -kernel $(VMLINUZ) -initrd $(INITRAMFSIMG) \
-         -hda emptydisk
-
-emptydisk:
-       rm -f emptydisk
-       dd if=/dev/zero of=emptydisk bs=1024 count=1440
-       echo 0, | sfdisk -q -C 80 -H 2 -S 18 emptydisk > /dev/null
-
-# This is a more realistic test boot command line which better
-# reflects what the library does.
-
-test-boot-realistic: emptydisk
-       qemu-system-$(host_cpu) \
-         -m 384 \
-         -kernel $(VMLINUZ) -initrd $(INITRAMFSIMG) \
-         -hda emptydisk \
-         -append "console=ttyS0 guestfs=10.0.2.4:6666 guestfs_rescue=1" \
-         -nographic \
-         -serial stdio \
-         -net channel,6666:unix:/tmp/sock,server,nowait \
-         -net user,vlan=0 \
-         -net nic,model=virtio,vlan=0
+# Extra symlinks needed by the Debian appliance.
+debirf_symlinks = \
+       a0_prep-root \
+       install-kernel \
+       z0_remove-aptitude \
+       z0_remove-locales \
+       z1_clean-root
+noinst_DATA = $(debirf_symlinks:%=debian/modules/%)
+$(debirf_symlinks:%=debian/modules/%): stamp-debirf-modules
+stamp-debirf-modules:
+       mkdir -p debian/modules
+       for f in $(debirf_symlinks); do \
+         ln -sf /usr/share/debirf/modules/$$f debian/modules/$$f; \
+       done
+       touch $@
 
 # Make clean.
 
-CLEANFILES = $(APPLIANCE_FILES)
+CLEANFILES = packagelist kmod.whitelist
 
 clean-local:
+       rm -f supermin.d/*
        rm -rf $(top_builddir)/initramfs
-