appliance: Remove repo from appliance filename (RHBZ#638901).
[libguestfs.git] / appliance / Makefile.am
index 157c875..0abd698 100644 (file)
@@ -21,7 +21,6 @@ EXTRA_DIST = \
        kmod.whitelist.in \
        packagelist.in \
        init \
-       debian/modules/install_kernel \
        debian/modules/y0_install-guestfsd \
        debian/modules/z99_final-cleanups \
        debian/debirf.conf.in \
@@ -48,13 +47,13 @@ superminfs_DATA = \
 endif
 
 # Don't change these names - they must be the same as in '*.sh' scripts.
-INITRAMFSIMG = initramfs.$(REPO).$(host_cpu).img
-VMLINUZ = vmlinuz.$(REPO).$(host_cpu)
+INITRAMFSIMG = initramfs.$(host_cpu).img
+VMLINUZ = vmlinuz.$(host_cpu)
 
 # This is for building the normal appliance:
 $(INITRAMFSIMG) $(VMLINUZ): $(top_builddir)/initramfs/fakeroot.log
 
-$(top_builddir)/initramfs/fakeroot.log: make.sh kmod.whitelist packagelist $(top_builddir)/daemon/guestfsd
+$(top_builddir)/initramfs/fakeroot.log: make.sh kmod.whitelist packagelist
        mv $(INITRAMFSIMG) $(INITRAMFSIMG).bak 2>/dev/null; :
        mv $(VMLINUZ) $(VMLINUZ).bak 2>/dev/null; :
        if ! bash make.sh; then rm -f $@; exit 1; fi
@@ -87,13 +86,16 @@ packagelist: packagelist.in
 if SUPERMIN
 
 supermin.d/base.img supermin.d/hostfiles: stamp-supermin
-stamp-supermin: $(top_builddir)/initramfs/fakeroot.log $(top_builddir)/initramfs/init
+stamp-supermin: $(INITRAMFSIMG)
        mkdir -p supermin.d
        rm -f $@ supermin.d/base.img supermin.d/hostfiles
        febootstrap-to-supermin $(top_builddir)/initramfs supermin.d/base.img supermin.d/hostfiles
+       if grep -q /usr/share/augeas/lenses supermin.d/hostfiles; then \
+               echo "./usr/share/augeas/lenses/*.aug" >> supermin.d/hostfiles; \
+       fi
        touch $@
 
-supermin.d/daemon.img: $(top_builddir)/initramfs/sbin/guestfsd
+supermin.d/daemon.img: $(INITRAMFSIMG)
        mkdir -p supermin.d
        rm -f $@ $@-t
        (cd $(top_builddir)/initramfs && \
@@ -104,6 +106,7 @@ endif
 # Extra symlinks needed by the Debian appliance.
 debirf_symlinks = \
        a0_prep-root \
+       install-kernel \
        z0_remove-aptitude \
        z0_remove-locales \
        z1_clean-root
@@ -116,37 +119,6 @@ stamp-debirf-modules:
        done
        touch $@
 
-#----------------------------------------------------------------------
-# Extra rules for testing the appliance.
-
-# Test-boot the appliance.
-
-test-boot: emptydisk
-       qemu-system-$(host_cpu) \
-         -m 384 \
-         -kernel $(VMLINUZ) -initrd $(INITRAMFSIMG) \
-         -hda emptydisk
-
-emptydisk:
-       rm -f emptydisk
-       dd if=/dev/zero of=emptydisk bs=1024 count=1440
-       echo 0, | sfdisk -q -C 80 -H 2 -S 18 emptydisk > /dev/null
-
-# This is a more realistic test boot command line which better
-# reflects what the library does.
-
-test-boot-realistic: emptydisk
-       qemu-system-$(host_cpu) \
-         -m 384 \
-         -kernel $(VMLINUZ) -initrd $(INITRAMFSIMG) \
-         -hda emptydisk \
-         -append "console=ttyS0 guestfs=10.0.2.4:6666 guestfs_rescue=1" \
-         -nographic \
-         -serial stdio \
-         -net channel,6666:unix:/tmp/sock,server,nowait \
-         -net user,vlan=0 \
-         -net nic,model=virtio,vlan=0
-
 # Make clean.
 
 CLEANFILES = packagelist kmod.whitelist