Ideas for the Python bindings: https://www.redhat.com/archives/fedora-virt/2009-April/msg00114.html ---------------------------------------------------------------------- We badly need to actually implement the FTP server mentioned in the documentation. Or: Implement a FUSE-based filesystem. See the FUSE mountlo project which does something similar, albeit only to single filesystems: http://sourceforge.net/project/showfiles.php?group_id=121684&package_id=150116 ---------------------------------------------------------------------- BufferIn and BufferOut should turn into and simple strings in other languages that can handle 8 bit clean strings. Limit on transfers would still be 2MB for these types. - then implement write-file properly - and implement read-file ---------------------------------------------------------------------- Implement febootstrap command. ---------------------------------------------------------------------- Complete the Haskell bindings (see discussion on haskell-cafe). ---------------------------------------------------------------------- Complete the bindings tests - must test the return values and error cases. ---------------------------------------------------------------------- For virt-inspector: - Make a libvirt XML config - Test over available OSes - Add 'reged' / NT registry support. ---------------------------------------------------------------------- Use virtio_blk by default. It's faster and more natural. Unfortunately it seems like this will rename all devices - see next item. ---------------------------------------------------------------------- "Device independent" naming for devices. With a Fedora-based appliance, using libata driver, devices have "SCSI" names like /dev/sda. With an EPEL-based appliance, using old ide driver, devices have names like /dev/hda. If we use virtio_blk, devices will have names like /dev/vda. What a mess. So the idea would be to add a device independent naming scheme, such as the one used by grub: "(hdX)" X = 0 means 'a', X = 1 means 'b' and so on. "(hdX,Y)" Device X, partition Y (in grub, this counts from 0 which is deeply confusing). There would have to be a very simple rule. If guestfsd was expecting a /dev block device or partition name, then the alternate form can be used, and we would just look it up using the normal output of guestfs_list_devices. Maybe best is to use /dev/sda as the "standard" naming. That shouldn't cause conflicts in the appliance because we tightly control what drivers are available. Note there's a lot of hackery that currently exists in tests.c which could be *removed* if we made this change. Open: Should the substitution be done in the library layer or in the daemon?