New patches from Fedora.
[fedora-mingw.git] / pangomm / mingw32-pangomm.spec
1 %define __strip %{_mingw32_strip}
2 %define __objdump %{_mingw32_objdump}
3 %define _use_internal_dependency_generator 0
4 %define __find_requires %{_mingw32_findrequires}
5 %define __find_provides %{_mingw32_findprovides}
6
7 %define apiver 1.4
8
9 Name:           mingw32-pangomm
10 Version:        2.14.0
11 Release:        6%{?dist}
12 Summary:        MinGW Windows C++ interface for Pango
13
14 License:        LGPLv2+
15 Group:          Development/Libraries
16 URL:            http://gtkmm.sourceforge.net/
17 Source0:        http://ftp.gnome.org/pub/GNOME/sources/pangomm/2.14/pangomm-%{version}.tar.bz2
18 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
19
20 Patch0:         pangomm-2.14.0-devhelp.patch
21
22 BuildArch:      noarch
23
24 BuildRequires:  mingw32-filesystem >= 30
25 BuildRequires:  mingw32-gcc
26 BuildRequires:  mingw32-gcc-c++
27 BuildRequires:  mingw32-binutils
28 BuildRequires:  mingw32-glibmm24 >= 2.14.1
29 BuildRequires:  mingw32-cairomm >= 1.2.2
30 BuildRequires:  mingw32-pango >= 1.21.4
31 BuildRequires:  doxygen
32 BuildRequires:  graphviz
33
34 Requires:       pkgconfig
35
36
37 %description
38 pangomm provides a C++ interface to the Pango library. Highlights
39 include typesafe callbacks, widgets extensible via inheritance and a
40 comprehensive set of widget classes that can be freely combined to
41 quickly create complex user interfaces.
42
43
44 %prep
45 %setup -q -n pangomm-%{version}
46 %patch0 -p1 -b .devhelp
47
48
49 %build
50 %{_mingw32_configure} --disable-static
51 make %{?_smp_mflags}
52
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56 make DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p" install
57
58 rm -r $RPM_BUILD_ROOT%{_mingw32_libdir}/pangomm-%{apiver}
59
60 # Remove documentation.
61 rm -r $RPM_BUILD_ROOT%{_mingw32_docdir}/pangomm-%{apiver}
62 rm -r $RPM_BUILD_ROOT%{_mingw32_datadir}/devhelp
63
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68
69 %files
70 %defattr(-,root,root)
71 %doc COPYING COPYING.tools
72 %{_mingw32_bindir}/libpangomm-%{apiver}-1.dll
73 %{_mingw32_libdir}/libpangomm-%{apiver}.la
74 %{_mingw32_libdir}/libpangomm-%{apiver}.dll.a
75 %{_mingw32_libdir}/pkgconfig/pangomm-%{apiver}.pc
76 %{_mingw32_includedir}/pangomm-%{apiver}
77
78
79 %changelog
80 * Fri Feb 20 2009 Richard W.M. Jones <rjones@redhat.com> - 2.14.0-6
81 - Rebuild for mingw32-gcc 4.4
82
83 * Fri Feb  6 2009 Richard W.M. Jones <rjones@redhat.com> - 2.14.0-5
84 - Include license file.
85
86 * Fri Jan 23 2009 Richard W.M. Jones <rjones@redhat.com> - 2.14.0-4
87 - Use _smp_mflags.
88
89 * Tue Jan 13 2009 Richard W.M. Jones <rjones@redhat.com> - 2.14.0-3
90 - Requires pkgconfig.
91
92 * Fri Oct 24 2008 Richard W.M. Jones <rjones@redhat.com> - 2.14.0-2
93 - Initial RPM release.