New patches from Fedora.
[fedora-mingw.git] / pango / mingw32-pango.spec
1 %define __strip %{_mingw32_strip}
2 %define __objdump %{_mingw32_objdump}
3 %define _use_internal_dependency_generator 0
4 %define __find_requires %{_mingw32_findrequires}
5 %define __find_provides %{_mingw32_findprovides}
6
7 Name:           mingw32-pango
8 Version:        1.23.0
9 Release:        1%{?dist}
10 Summary:        MinGW Windows Pango library
11
12 License:        LGPLv2+
13 Group:          Development/Libraries
14 URL:            http://www.pango.org
15 Source0:        http://download.gnome.org/sources/pango/1.23/pango-%{version}.tar.bz2
16
17 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
18
19 # Native pango uses a %post script to generate this, but the
20 # pango-querymodules.exe binary is not something we can easily run on
21 # a Linux host. We could use wine but wine isn't happy in a mock
22 # environment. So we just include a pre-generated copy on basis that
23 # it won't ever change much.
24 #
25 # If you want to rebuild this, do:
26 # wine %{_mingw32_bindir}/pango-querymodules.exe > pango.modules
27 Source1:        pango.modules
28
29 Patch1000:      pango_enable_static_build.patch
30
31 BuildArch:      noarch
32
33 BuildRequires:  mingw32-filesystem >= 23
34 BuildRequires:  mingw32-gcc
35 BuildRequires:  mingw32-binutils
36
37 BuildRequires:  mingw32-cairo >= 1.8.0
38 BuildRequires:  mingw32-dlfcn
39 BuildRequires:  mingw32-expat
40 BuildRequires:  mingw32-fontconfig
41 BuildRequires:  mingw32-freetype
42 BuildRequires:  mingw32-gettext
43 BuildRequires:  mingw32-glib2
44 BuildRequires:  mingw32-iconv
45 BuildRequires:  mingw32-libpng
46 BuildRequires:  mingw32-pixman
47 BuildRequires:  pkgconfig
48
49 # Required in order to rebuild the configure script.
50 BuildRequires:  gtk-doc
51
52 # These are required for the patch
53 BuildRequires:  autoconf, automake, libtool
54
55 Requires:       pkgconfig
56
57
58 %description
59 MinGW Windows Pango library.
60
61
62 %package static
63 Summary:        Static version of the MinGW Windows Pango library
64 Requires:       %{name} = %{version}-%{release}
65 Group:          Development/Libraries
66
67 %description static
68 Static version of the MinGW Windows Pango library.
69
70
71 %prep
72 %setup -q -n pango-%{version}
73 %patch1000
74
75 # Regenerate the configure script
76 aclocal
77 autoreconf
78 libtoolize
79
80
81 %build
82 # Need to run the correct version of glib-mkenums.
83 PATH=%{_mingw32_bindir}:$PATH \
84 %{_mingw32_configure} --enable-static --enable-shared
85 make %{?_smp_mflags}
86
87
88 %install
89 rm -rf $RPM_BUILD_ROOT
90
91 make DESTDIR=$RPM_BUILD_ROOT install
92
93 mkdir -p $RPM_BUILD_ROOT%{_mingw32_sysconfdir}/pango/
94 cp %{SOURCE1} $RPM_BUILD_ROOT%{_mingw32_sysconfdir}/pango/
95
96 rm -f $RPM_BUILD_ROOT/%{_mingw32_libdir}/charset.alias
97
98 rm $RPM_BUILD_ROOT/%{_mingw32_mandir}/man1/*.1
99
100
101 %clean
102 rm -rf $RPM_BUILD_ROOT
103
104
105 %files
106 %defattr(-,root,root,-)
107 %doc COPYING
108 %{_mingw32_bindir}/libpango-1.0-0.dll
109 %{_mingw32_bindir}/libpangocairo-1.0-0.dll
110 %{_mingw32_bindir}/libpangoft2-1.0-0.dll
111 %{_mingw32_bindir}/libpangowin32-1.0-0.dll
112 %{_mingw32_bindir}/pango-querymodules.exe
113 %{_mingw32_includedir}/pango-1.0/
114 %{_mingw32_libdir}/libpango-1.0.dll.a
115 %{_mingw32_libdir}/libpango-1.0.la
116 %{_mingw32_libdir}/libpangocairo-1.0.dll.a
117 %{_mingw32_libdir}/libpangocairo-1.0.la
118 %{_mingw32_libdir}/libpangoft2-1.0.dll.a
119 %{_mingw32_libdir}/libpangoft2-1.0.la
120 %{_mingw32_libdir}/libpangowin32-1.0.dll.a
121 %{_mingw32_libdir}/libpangowin32-1.0.la
122 %{_mingw32_libdir}/pango-1.0.def
123 %{_mingw32_libdir}/pangocairo-1.0.def
124 %{_mingw32_libdir}/pangoft2-1.0.def
125 %{_mingw32_libdir}/pangowin32-1.0.def
126 %dir %{_mingw32_libdir}/pango
127 %dir %{_mingw32_libdir}/pango/1.6.0
128 %dir %{_mingw32_libdir}/pango/1.6.0/modules
129 %{_mingw32_libdir}/pango/1.6.0/modules/pango-basic-win32.dll
130 %{_mingw32_libdir}/pango/1.6.0/modules/pango-basic-win32.dll.a
131 %{_mingw32_libdir}/pango/1.6.0/modules/pango-basic-win32.la
132 %{_mingw32_libdir}/pango/1.6.0/modules/pango-arabic-lang.dll
133 %{_mingw32_libdir}/pango/1.6.0/modules/pango-arabic-lang.dll.a
134 %{_mingw32_libdir}/pango/1.6.0/modules/pango-arabic-lang.la
135 %{_mingw32_libdir}/pango/1.6.0/modules/pango-indic-lang.dll
136 %{_mingw32_libdir}/pango/1.6.0/modules/pango-indic-lang.dll.a
137 %{_mingw32_libdir}/pango/1.6.0/modules/pango-indic-lang.la
138 %{_mingw32_libdir}/pango/1.6.0/modules/pango-arabic-fc.dll
139 %{_mingw32_libdir}/pango/1.6.0/modules/pango-arabic-fc.dll.a
140 %{_mingw32_libdir}/pango/1.6.0/modules/pango-arabic-fc.la
141 %{_mingw32_libdir}/pango/1.6.0/modules/pango-basic-fc.dll
142 %{_mingw32_libdir}/pango/1.6.0/modules/pango-basic-fc.dll.a
143 %{_mingw32_libdir}/pango/1.6.0/modules/pango-basic-fc.la
144 %{_mingw32_libdir}/pango/1.6.0/modules/pango-hangul-fc.dll
145 %{_mingw32_libdir}/pango/1.6.0/modules/pango-hangul-fc.dll.a
146 %{_mingw32_libdir}/pango/1.6.0/modules/pango-hangul-fc.la
147 %{_mingw32_libdir}/pango/1.6.0/modules/pango-hebrew-fc.dll
148 %{_mingw32_libdir}/pango/1.6.0/modules/pango-hebrew-fc.dll.a
149 %{_mingw32_libdir}/pango/1.6.0/modules/pango-hebrew-fc.la
150 %{_mingw32_libdir}/pango/1.6.0/modules/pango-indic-fc.dll
151 %{_mingw32_libdir}/pango/1.6.0/modules/pango-indic-fc.dll.a
152 %{_mingw32_libdir}/pango/1.6.0/modules/pango-indic-fc.la
153 %{_mingw32_libdir}/pango/1.6.0/modules/pango-khmer-fc.dll
154 %{_mingw32_libdir}/pango/1.6.0/modules/pango-khmer-fc.dll.a
155 %{_mingw32_libdir}/pango/1.6.0/modules/pango-khmer-fc.la
156 %{_mingw32_libdir}/pango/1.6.0/modules/pango-syriac-fc.dll
157 %{_mingw32_libdir}/pango/1.6.0/modules/pango-syriac-fc.dll.a
158 %{_mingw32_libdir}/pango/1.6.0/modules/pango-syriac-fc.la
159 %{_mingw32_libdir}/pango/1.6.0/modules/pango-thai-fc.dll
160 %{_mingw32_libdir}/pango/1.6.0/modules/pango-thai-fc.dll.a
161 %{_mingw32_libdir}/pango/1.6.0/modules/pango-thai-fc.la
162 %{_mingw32_libdir}/pango/1.6.0/modules/pango-tibetan-fc.dll
163 %{_mingw32_libdir}/pango/1.6.0/modules/pango-tibetan-fc.dll.a
164 %{_mingw32_libdir}/pango/1.6.0/modules/pango-tibetan-fc.la
165 %{_mingw32_libdir}/pkgconfig/pango.pc
166 %{_mingw32_libdir}/pkgconfig/pangocairo.pc
167 %{_mingw32_libdir}/pkgconfig/pangoft2.pc
168 %{_mingw32_libdir}/pkgconfig/pangowin32.pc
169 %{_mingw32_datadir}/gtk-doc/html/pango/
170 %{_mingw32_sysconfdir}/pango/
171
172
173 %files static
174 %defattr(-,root,root,-)
175 %{_mingw32_libdir}/libpango-1.0.a
176 %{_mingw32_libdir}/libpangocairo-1.0.a
177 %{_mingw32_libdir}/libpangoft2-1.0.a
178 %{_mingw32_libdir}/libpangowin32-1.0.a
179 %{_mingw32_libdir}/pango/1.6.0/modules/pango-basic-win32.a
180 %{_mingw32_libdir}/pango/1.6.0/modules/pango-arabic-lang.a
181 %{_mingw32_libdir}/pango/1.6.0/modules/pango-indic-lang.a
182 %{_mingw32_libdir}/pango/1.6.0/modules/pango-arabic-fc.a
183 %{_mingw32_libdir}/pango/1.6.0/modules/pango-basic-fc.a
184 %{_mingw32_libdir}/pango/1.6.0/modules/pango-hangul-fc.a
185 %{_mingw32_libdir}/pango/1.6.0/modules/pango-hebrew-fc.a
186 %{_mingw32_libdir}/pango/1.6.0/modules/pango-indic-fc.a
187 %{_mingw32_libdir}/pango/1.6.0/modules/pango-khmer-fc.a
188 %{_mingw32_libdir}/pango/1.6.0/modules/pango-syriac-fc.a
189 %{_mingw32_libdir}/pango/1.6.0/modules/pango-thai-fc.a
190 %{_mingw32_libdir}/pango/1.6.0/modules/pango-tibetan-fc.a
191   
192
193 %changelog
194 * Mon Mar  9 2009 Richard W.M. Jones <rjones@redhat.com> - 1.23.0-1
195 - Remove man page which duplicates what is in base Fedora.
196 - Rebase to 1.23.0 to match Fedora.
197 - +BR mingw32-dlfcn.
198
199 * Fri Feb 20 2009 Erik van Pienbroek <info@nntpgrab.nl> - 1.22.1-6
200 - Added -static subpackage
201
202 * Fri Feb 20 2009 Richard W.M. Jones <rjones@redhat.com> - 1.22.1-5
203 - Rebuild for mingw32-gcc 4.4
204
205 * Fri Jan 30 2009 Richard W.M. Jones <rjones@redhat.com> - 1.22.1-4
206 - Requires pkgconfig.
207
208 * Tue Jan 27 2009 Levente Farkas <lfarkas@lfarkas.org> - 1.22.1-3
209 - Include license file in documentation section.
210
211 * Fri Jan 23 2009 Richard W.M. Jones <rjones@redhat.com> - 1.22.1-2
212 - Disable static libraries.
213 - Use _smp_mflags.
214
215 * Fri Oct 24 2008 Richard W.M. Jones <rjones@redhat.com> - 1.22.1-1
216 - New upstream version 1.22.1.
217 - BR cairo >= 1.8.0 because of important fixes.
218
219 * Wed Sep 24 2008 Richard W.M. Jones <rjones@redhat.com> - 1.21.6-6
220 - Rename mingw -> mingw32.
221
222 * Tue Sep 23 2008 Daniel P. Berrange <berrange@redhat.com> - 1.21.6-5
223 - Remove use of wine in %-post.
224
225 * Thu Sep 11 2008 Daniel P. Berrange <berrange@redhat.com> - 1.21.6-4
226 - Add dep on pkgconfig
227
228 * Thu Sep 11 2008 Richard W.M. Jones <rjones@redhat.com> - 1.21.6-3
229 - post/preun scripts to update the pango.modules list.
230
231 * Wed Sep 10 2008 Richard W.M. Jones <rjones@redhat.com> - 1.21.6-2
232 - Run the correct glib-mkenums.
233
234 * Tue Sep  9 2008 Daniel P. Berrange <berrange@redhat.com> - 1.21.6-1
235 - Initial RPM release