28ea035bc39d22f2d78f201f776e52298d09e5eb
[fedora-mingw.git] / libvirt / mingw32-libvirt.spec
1 %define __strip %{_mingw32_strip}
2 %define __objdump %{_mingw32_objdump}
3 %define _use_internal_dependency_generator 0
4 %define __find_requires %{_mingw32_findrequires}
5 %define __find_provides %{_mingw32_findprovides}
6
7 Name:           mingw32-libvirt
8 Version:        0.6.1
9 Release:        1%{?dist}%{?extra_release}
10 Summary:        MinGW Windows libvirt virtualization library
11
12 License:        LGPLv2+
13 Group:          Development/Libraries
14 URL:            http://libvirt.org/
15 Source0:        ftp://libvirt.org/libvirt/libvirt-%{version}.tar.gz
16 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
17
18 BuildRequires:  mingw32-filesystem >= 23
19 BuildRequires:  mingw32-gcc
20 BuildRequires:  mingw32-binutils
21 BuildRequires:  mingw32-libgpg-error
22 BuildRequires:  mingw32-libgcrypt
23 BuildRequires:  mingw32-gnutls
24 BuildRequires:  mingw32-gettext
25 BuildRequires:  mingw32-libxml2
26 # Portable XDR <= 4.0.10 contains a serious endianness bug on Windows.
27 BuildRequires:  mingw32-portablexdr >= 4.0.11
28 BuildRequires:  mingw32-readline
29 BuildRequires:  mingw32-termcap >= 1.3.1-3
30 BuildRequires:  pkgconfig
31
32 # Need native version for msgfmt
33 BuildRequires:  gettext
34
35 BuildArch:      noarch
36
37 Requires:       pkgconfig
38
39
40 %description
41 MinGW Windows libvirt virtualization library.
42
43
44 %prep
45 %setup -q -n libvirt-%{version}
46
47
48 %build
49 # XXX enable SASL in future
50 %{_mingw32_configure} \
51   --without-sasl \
52   --without-avahi \
53   --without-polkit \
54   --without-python \
55   --without-xen \
56   --without-qemu \
57   --without-lxc \
58   --without-uml \
59   --without-openvz \
60   --without-libvirtd \
61   --disable-static
62 make %{?_smp_mflags}
63
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67
68 make DESTDIR=$RPM_BUILD_ROOT install
69
70 rm -rf $RPM_BUILD_ROOT%{_mingw32_sysconfdir}/libvirt
71 rm -rf $RPM_BUILD_ROOT%{_mingw32_datadir}/doc/*
72 rm -rf $RPM_BUILD_ROOT%{_mingw32_datadir}/gtk-doc/*
73
74 %find_lang libvirt
75
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80
81 %files -f libvirt.lang
82 %defattr(-,root,root)
83 %doc COPYING.LIB
84 %{_mingw32_bindir}/libvirt-0.dll
85 %{_mingw32_bindir}/virsh.exe
86
87 %{_mingw32_libdir}/libvirt.dll.a
88 %{_mingw32_libdir}/libvirt.la
89 %{_mingw32_libdir}/pkgconfig/libvirt.pc
90
91 %dir %{_mingw32_datadir}/libvirt/
92 %dir %{_mingw32_datadir}/libvirt/schemas/
93 %{_mingw32_datadir}/libvirt/schemas/domain.rng
94 %{_mingw32_datadir}/libvirt/schemas/network.rng
95 %{_mingw32_datadir}/libvirt/schemas/storagepool.rng
96 %{_mingw32_datadir}/libvirt/schemas/storagevol.rng
97 %{_mingw32_datadir}/libvirt/schemas/nodedev.rng
98 %{_mingw32_datadir}/libvirt/schemas/capability.rng
99
100 %dir %{_mingw32_includedir}/libvirt
101 %{_mingw32_includedir}/libvirt/libvirt.h
102 %{_mingw32_includedir}/libvirt/virterror.h
103
104 %{_mingw32_mandir}/man1/virsh.1*
105
106
107 %changelog
108 * Fri Feb 20 2009 Richard W.M. Jones <rjones@redhat.com> - 0.5.1-4
109 - Rebuild for mingw32-gcc 4.4
110
111 * Fri Jan 30 2009 Richard Jones <rjones@redhat.com> - 0.5.1-3
112 - Include license file.
113
114 * Fri Jan 30 2009 Richard Jones <rjones@redhat.com> - 0.5.1-2
115 - Requires pkgconfig.
116
117 * Fri Jan 23 2009 Richard Jones <rjones@redhat.com> - 0.5.1-1
118 - Rebase to Fedora native version 0.5.1.
119 - Use find_lang macro.
120 - Use _smp_mflags.
121 - Disable static libraries.
122
123 * Wed Nov 26 2008 Richard Jones <rjones@redhat.com> - 0.5.0-1
124 - New upstream version 0.5.0.
125
126 * Sat Nov 22 2008 Richard Jones <rjones@redhat.com> - 0.4.6-9
127 - Rebuild against new readline.
128
129 * Fri Oct 31 2008 Richard Jones <rjones@redhat.com> - 0.4.6-8
130 - Rebuild against latest termcap.
131
132 * Thu Oct 16 2008 Richard Jones <rjones@redhat.com> - 0.4.6-7
133 - Windows icon patch from
134   https://www.redhat.com/archives/libvir-list/2008-October/msg00331.html
135
136 * Wed Oct 15 2008 Richard Jones <rjones@redhat.com> - 0.4.6-6
137 - Add patches from
138   https://www.redhat.com/archives/libvir-list/2008-October/msg00328.html
139 - BR mingw32-portablexdr >= 4.0.11 to fix serious Windows endianness bug.
140
141 * Tue Oct 14 2008 Richard Jones <rjones@redhat.com> - 0.4.6-4
142 - +BR mingw32-readline.
143
144 * Thu Sep 25 2008 Richard Jones <rjones@redhat.com> - 0.4.6-3
145 - BuildArch should be noarch
146
147 * Wed Sep 24 2008 Richard W.M. Jones <rjones@redhat.com> - 0.4.6-2
148 - Whitespace removal.
149
150 * Wed Sep 24 2008 Richard W.M. Jones <rjones@redhat.com> - 0.4.6-1
151 - New upstream release 0.4.6.
152 - Rename mingw -> mingw32.
153
154 * Mon Sep 22 2008 Daniel P. Berrange <berrange@redhat.com> - 0.4.5-4%{?extra_release}
155 - Import crash fix from rawhide
156
157 * Thu Sep 11 2008 Daniel P. Berrange <berrange@redhat.com> - 0.4.5-3%{?extra_release}
158 - Add dep on gettext & pkgconfig
159
160 * Wed Sep 10 2008 Richard W.M. Jones <rjones@redhat.com> - 0.4.5-2
161 - Remove static lib.
162
163 * Tue Sep  2 2008 Daniel P. Berrange <berrange@redhat.com> - 0.4.4-1
164 - Initial RPM release, largely based on earlier work from several sources.