361239881d9d7556ca6d5f779687f0b84f53d1f4
[fedora-mingw.git] / libidn / mingw32-libidn.spec
1 %define __strip %{_mingw32_strip}
2 %define __objdump %{_mingw32_objdump}
3 %define _use_internal_dependency_generator 0
4 %define __find_requires %{_mingw32_findrequires}
5 %define __find_provides %{_mingw32_findprovides}
6
7 # Native Fedora package is ancient, 0.6.14, which doesn't even
8 # exist on the upstream servers any more.  I have gone for the
9 # latest version instead.
10
11 Name:           mingw32-libidn
12 Version:        1.9
13 Release:        4%{?dist}
14 Summary:        MinGW Windows Internationalized Domain Name support library
15
16 License:        LGPLv2+
17 Group:          Development/Libraries
18 URL:            http://www.gnu.org/software/libidn/
19 Source0:        http://josefsson.org/libidn/releases/libidn-%{version}.tar.gz
20 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
21
22 #Patch0:         libidn-0.6.14-aconf262.patch
23
24 BuildArch:      noarch
25
26 BuildRequires:  mingw32-filesystem >= 33
27 BuildRequires:  mingw32-gcc
28 BuildRequires:  mingw32-binutils
29 BuildRequires:  mingw32-gettext
30 BuildRequires:  mingw32-iconv
31 BuildRequires:  pkgconfig, gettext
32 #BuildRequires:  libtool, automake, autoconf
33
34 Requires:       pkgconfig
35
36
37 %description
38 GNU Libidn is an implementation of the Stringprep, Punycode and
39 IDNA specifications defined by the IETF Internationalized Domain
40 Names (IDN) working group, used for internationalized domain
41 names.
42
43
44 %prep
45 %setup -q -n libidn-%{version}
46 #%patch0 -p1 -b .aconf262
47 #autoreconf
48
49
50 %build
51 %{_mingw32_configure} --disable-csharp --disable-static
52 make %{?_smp_mflags}
53
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57 make DESTDIR=$RPM_BUILD_ROOT install
58
59 # Remove documentation which duplicates native Fedora package.
60 rm -r $RPM_BUILD_ROOT%{_mingw32_datadir}/emacs
61 rm -r $RPM_BUILD_ROOT%{_mingw32_infodir}
62 rm -r $RPM_BUILD_ROOT%{_mingw32_mandir}/man*
63
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68
69 %files
70 %defattr(-,root,root)
71 %doc COPYING COPYING.LIB
72 %{_mingw32_bindir}/idn.exe
73 %{_mingw32_bindir}/libidn-11.dll
74 %{_mingw32_libdir}/libidn.dll.a
75 %{_mingw32_libdir}/libidn.la
76 %{_mingw32_libdir}/pkgconfig/libidn.pc
77 %{_mingw32_includedir}/*.h
78 %{_mingw32_datadir}/locale/*/LC_MESSAGES/libidn.mo
79
80
81 %changelog
82 * Fri Feb 20 2009 Richard W.M. Jones <rjones@redhat.com> - 1.9-4
83 - Rebuild for mingw32-gcc 4.4
84
85 * Fri Feb  6 2009 Richard W.M. Jones <rjones@redhat.com> - 0.6.14-3
86 - Include license file.
87
88 * Fri Jan 30 2009 Richard W.M. Jones <rjones@redhat.com> - 0.6.14-2
89 - Requires pkgconfig.
90
91 * Mon Nov 10 2008 Richard W.M. Jones <rjones@redhat.com> - 0.6.14-1
92 - Initial RPM release.