New patches from Fedora.
[fedora-mingw.git] / expat / mingw32-expat.spec
1 %define __strip %{_mingw32_strip}
2 %define __objdump %{_mingw32_objdump}
3 %define _use_internal_dependency_generator 0
4 %define __find_requires %{_mingw32_findrequires}
5 %define __find_provides %{_mingw32_findprovides}
6
7 Name:           mingw32-expat
8 Version:        2.0.1
9 Release:        4%{?dist}
10 Summary:        MinGW Windows port of expat XML parser library
11
12 License:        MIT
13 Group:          Development/Libraries
14 URL:            http://www.libexpat.org/
15 Source0:        http://download.sourceforge.net/expat/expat-%{version}.tar.gz
16 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
17
18 BuildArch:      noarch
19
20 BuildRequires:  mingw32-filesystem >= 33
21 BuildRequires:  mingw32-gcc
22 BuildRequires:  mingw32-binutils
23 BuildRequires:  autoconf, automake, libtool
24
25
26 %description
27 This is expat, the C library for parsing XML, written by James Clark. Expat
28 is a stream oriented XML parser. This means that you register handlers with
29 the parser prior to starting the parse. These handlers are called when the
30 parser discovers the associated structures in the document being parsed. A
31 start tag is an example of the kind of structures for which you may
32 register handlers.
33
34
35 %prep
36 %setup -q -n expat-%{version}
37
38 rm -rf autom4te*.cache
39 cp `aclocal --print-ac-dir`/libtool.m4 conftools || exit 1
40 libtoolize --copy --force --automake && aclocal && autoheader && autoconf
41
42 chmod -x COPYING
43
44
45 %build
46 %{_mingw32_configure}
47 make %{?_smp_mflags}
48
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52 make DESTDIR=$RPM_BUILD_ROOT install
53
54 # Remove static libraries but DON'T remove *.dll.a files.
55 rm $RPM_BUILD_ROOT%{_mingw32_libdir}/libexpat.a
56
57 # Remove documentation which duplicates that found in the native package.
58 rm -r $RPM_BUILD_ROOT%{_mingw32_mandir}/man1
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63
64 %files
65 %defattr(-,root,root)
66 %doc COPYING
67 %{_mingw32_bindir}/libexpat-1.dll
68 %{_mingw32_bindir}/xmlwf
69 %{_mingw32_libdir}/libexpat.dll.a
70 %{_mingw32_libdir}/libexpat.la
71 %{_mingw32_includedir}/expat.h
72 %{_mingw32_includedir}/expat_external.h
73
74
75 %changelog
76 * Mon Mar  9 2009 Richard W.M. Jones <rjones@redhat.com> - 2.0.1-4
77 - Remove +x permissions on COPYING file.
78
79 * Fri Feb 20 2009 Richard W.M. Jones <rjones@redhat.com> - 2.0.1-3
80 - Rebuild for mingw32-gcc 4.4
81
82 * Fri Feb  6 2009 Richard W.M. Jones <rjones@redhat.com> - 2.0.1-2
83 - Include license.
84
85 * Fri Oct 31 2008 Richard W.M. Jones <rjones@redhat.com> - 2.0.1-1
86 - Initial RPM release.