639ff462fefd3866bb6808747de17d54dc064323
[fedora-mingw.git] / cairomm / mingw32-cairomm.spec
1 %define __strip %{_mingw32_strip}
2 %define __objdump %{_mingw32_objdump}
3 %define _use_internal_dependency_generator 0
4 %define __find_requires %{_mingw32_findrequires}
5 %define __find_provides %{_mingw32_findprovides}
6
7 Name:           mingw32-cairomm
8 Version:        1.6.2
9 Release:        5%{?dist}
10 Summary:        MinGW Windows C++ API for the cairo graphics library
11
12 License:        LGPLv2+
13 Group:          Development/Libraries
14 URL:            http://www.cairographics.org
15 Source0:        http://www.cairographics.org/releases/cairomm-%{version}.tar.gz
16 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
17
18 BuildArch:      noarch
19
20 BuildRequires:  mingw32-filesystem >= 30
21 BuildRequires:  mingw32-gcc
22 BuildRequires:  mingw32-gcc-c++
23 BuildRequires:  mingw32-binutils
24 BuildRequires:  mingw32-cairo
25 BuildRequires:  pkgconfig
26
27 Requires:       pkgconfig
28
29
30 %description
31 Cairomm is the C++ API for the cairo graphics library. It offers all the power
32 of cairo with an interface familiar to C++ developers, including use of the 
33 Standard Template Library where it makes sense.
34
35
36 %prep
37 %setup -q -n cairomm-%{version}
38
39
40 %build
41 %{_mingw32_configure} --enable-static=no --enable-docs=no
42 make %{?_smp_mflags}
43
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47 make DESTDIR=$RPM_BUILD_ROOT install
48
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53
54 %files
55 %defattr(-,root,root)
56 %doc COPYING
57 %{_mingw32_bindir}/libcairomm-1.0-1.dll
58 %{_mingw32_libdir}/libcairomm-1.0.dll.a
59 %{_mingw32_libdir}/libcairomm-1.0.la
60 %{_mingw32_libdir}/pkgconfig/cairomm-1.0.pc
61 %{_mingw32_includedir}/cairomm-1.0
62
63
64 %changelog
65 * Fri Feb 20 2009 Richard W.M. Jones <rjones@redhat.com> - 1.6.2-5
66 - Rebuild for mingw32-gcc 4.4
67
68 * Fri Feb  6 2009 Richard W.M. Jones <rjones@redhat.com> - 1.6.2-4
69 - Include license.
70
71 * Fri Jan 23 2009 Richard W.M. Jones <rjones@redhat.com> - 1.6.2-3
72 - Use _smp_mflags.
73
74 * Fri Oct 24 2008 Richard W.M. Jones <rjones@redhat.com> - 1.6.2-2
75 - Initial RPM release.